summaryrefslogtreecommitdiffstats
path: root/vendor/sharded-slab/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/sharded-slab/Cargo.toml')
-rw-r--r--vendor/sharded-slab/Cargo.toml51
1 files changed, 51 insertions, 0 deletions
diff --git a/vendor/sharded-slab/Cargo.toml b/vendor/sharded-slab/Cargo.toml
new file mode 100644
index 000000000..210621ade
--- /dev/null
+++ b/vendor/sharded-slab/Cargo.toml
@@ -0,0 +1,51 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "sharded-slab"
+version = "0.1.4"
+authors = ["Eliza Weisman <eliza@buoyant.io>"]
+description = "A lock-free concurrent slab.\n"
+homepage = "https://github.com/hawkw/sharded-slab"
+documentation = "https://docs.rs/sharded-slab/0.1.4/sharded_slab"
+readme = "README.md"
+keywords = ["slab", "allocator", "lock-free", "atomic"]
+categories = ["memory-management", "data-structures", "concurrency"]
+license = "MIT"
+repository = "https://github.com/hawkw/sharded-slab"
+[package.metadata.docs.rs]
+all-features = true
+rustdoc-args = ["--cfg", "docsrs"]
+
+[[bench]]
+name = "bench"
+harness = false
+[dependencies.lazy_static]
+version = "1"
+[dev-dependencies.criterion]
+version = "0.3"
+
+[dev-dependencies.loom]
+version = "0.5"
+features = ["checkpoint"]
+
+[dev-dependencies.proptest]
+version = "1"
+
+[dev-dependencies.slab]
+version = "0.4.2"
+[target."cfg(loom)".dependencies.loom]
+version = "0.5"
+features = ["checkpoint"]
+optional = true
+[badges.maintenance]
+status = "experimental"