summaryrefslogtreecommitdiffstats
path: root/vendor/sharded-slab/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/sharded-slab/flake.nix')
-rw-r--r--vendor/sharded-slab/flake.nix28
1 files changed, 28 insertions, 0 deletions
diff --git a/vendor/sharded-slab/flake.nix b/vendor/sharded-slab/flake.nix
new file mode 100644
index 000000000..a38cc2a10
--- /dev/null
+++ b/vendor/sharded-slab/flake.nix
@@ -0,0 +1,28 @@
+# in flake.nix
+{
+ description =
+ "Flake containing a development shell for the `sharded-slab` crate";
+
+ inputs = {
+ nixpkgs.url = "github:NixOS/nixpkgs/nixos-unstable";
+ flake-utils.url = "github:numtide/flake-utils";
+ rust-overlay = {
+ url = "github:oxalica/rust-overlay";
+ inputs = {
+ nixpkgs.follows = "nixpkgs";
+ flake-utils.follows = "flake-utils";
+ };
+ };
+ };
+
+ outputs = { self, nixpkgs, flake-utils, rust-overlay }:
+ flake-utils.lib.eachDefaultSystem (system:
+ let
+ overlays = [ (import rust-overlay) ];
+ pkgs = import nixpkgs { inherit system overlays; };
+ rustToolchain = pkgs.pkgsBuildHost.rust-bin.stable.latest.default;
+ nativeBuildInputs = with pkgs; [ rustToolchain pkg-config ];
+ in with pkgs; {
+ devShells.default = mkShell { inherit nativeBuildInputs; };
+ });
+}