summaryrefslogtreecommitdiffstats
path: root/vendor/signature/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/signature/Cargo.toml')
-rw-r--r--vendor/signature/Cargo.toml11
1 files changed, 7 insertions, 4 deletions
diff --git a/vendor/signature/Cargo.toml b/vendor/signature/Cargo.toml
index 2d2391580..871099e1c 100644
--- a/vendor/signature/Cargo.toml
+++ b/vendor/signature/Cargo.toml
@@ -11,9 +11,9 @@
[package]
edition = "2021"
-rust-version = "1.56"
+rust-version = "1.60"
name = "signature"
-version = "2.1.0"
+version = "2.2.0"
authors = ["RustCrypto Developers"]
description = "Traits for cryptographic signature algorithms (e.g. ECDSA, Ed25519)"
documentation = "https://docs.rs/signature"
@@ -55,7 +55,7 @@ optional = true
default-features = false
[dev-dependencies.hex-literal]
-version = "0.3"
+version = "0.4"
[dev-dependencies.sha2]
version = "0.10"
@@ -63,4 +63,7 @@ default-features = false
[features]
alloc = []
-std = ["alloc"]
+std = [
+ "alloc",
+ "rand_core?/std",
+]