summaryrefslogtreecommitdiffstats
path: root/vendor/smallvec/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/smallvec/Cargo.toml')
-rw-r--r--vendor/smallvec/Cargo.toml44
1 files changed, 44 insertions, 0 deletions
diff --git a/vendor/smallvec/Cargo.toml b/vendor/smallvec/Cargo.toml
new file mode 100644
index 000000000..fd490da15
--- /dev/null
+++ b/vendor/smallvec/Cargo.toml
@@ -0,0 +1,44 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "smallvec"
+version = "1.9.0"
+authors = ["The Servo Project Developers"]
+description = "'Small vector' optimization: store up to a small number of items on the stack"
+documentation = "https://docs.rs/smallvec/"
+readme = "README.md"
+keywords = ["small", "vec", "vector", "stack", "no_std"]
+categories = ["data-structures"]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/servo/rust-smallvec"
+[package.metadata.docs.rs]
+all-features = true
+rustdoc-args = ["--cfg", "docsrs"]
+[dependencies.arbitrary]
+version = "1"
+optional = true
+
+[dependencies.serde]
+version = "1"
+optional = true
+default-features = false
+[dev-dependencies.bincode]
+version = "1.0.1"
+
+[features]
+const_generics = []
+const_new = ["const_generics"]
+may_dangle = []
+specialization = []
+union = []
+write = []