summaryrefslogtreecommitdiffstats
path: root/vendor/snap/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/snap/Cargo.toml')
-rw-r--r--vendor/snap/Cargo.toml35
1 files changed, 35 insertions, 0 deletions
diff --git a/vendor/snap/Cargo.toml b/vendor/snap/Cargo.toml
new file mode 100644
index 000000000..8559a1e4b
--- /dev/null
+++ b/vendor/snap/Cargo.toml
@@ -0,0 +1,35 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "snap"
+version = "1.0.5"
+authors = ["Andrew Gallant <jamslam@gmail.com>"]
+exclude = ["data/*"]
+description = "A pure Rust implementation of the Snappy compression algorithm. Includes\nstreaming compression and decompression.\n"
+homepage = "https://github.com/BurntSushi/rust-snappy"
+documentation = "https://docs.rs/snap"
+readme = "README.md"
+keywords = ["snappy", "compress", "compression", "decompress", "decompression"]
+license = "BSD-3-Clause"
+repository = "https://github.com/BurntSushi/rust-snappy"
+[profile.release]
+debug = true
+
+[profile.test]
+opt-level = 3
+
+[lib]
+bench = false
+[dev-dependencies.doc-comment]
+version = "0.3.1"