summaryrefslogtreecommitdiffstats
path: root/vendor/spdx-rs/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/spdx-rs/Cargo.toml')
-rw-r--r--vendor/spdx-rs/Cargo.toml62
1 files changed, 62 insertions, 0 deletions
diff --git a/vendor/spdx-rs/Cargo.toml b/vendor/spdx-rs/Cargo.toml
new file mode 100644
index 000000000..069cf2a1f
--- /dev/null
+++ b/vendor/spdx-rs/Cargo.toml
@@ -0,0 +1,62 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "spdx-rs"
+version = "0.5.1"
+authors = ["Mikko Murto <mikko.murto@hhpartners.fi>"]
+exclude = [
+ "/tests/",
+ "/.github/",
+ "/.gitignore",
+]
+description = "Parse and interact with SPDX Documents"
+homepage = "https://github.com/doubleopen-project/spdx-rs"
+documentation = "https://docs.rs/spdx-rs"
+readme = "README.md"
+keywords = ["SPDX"]
+categories = ["data-structures"]
+license = "MIT"
+repository = "https://github.com/doubleopen-project/spdx-rs"
+
+[dependencies.chrono]
+version = "0.4"
+features = ["serde"]
+
+[dependencies.log]
+version = "0.4"
+
+[dependencies.nom]
+version = "7"
+
+[dependencies.serde]
+version = "1"
+features = ["derive"]
+
+[dependencies.spdx-expression]
+version = "0.5.2"
+
+[dependencies.strum]
+version = "0.24"
+
+[dependencies.strum_macros]
+version = "0.24"
+
+[dependencies.thiserror]
+version = "1"
+
+[dependencies.uuid]
+version = "0.8"
+features = ["v4"]
+
+[dev-dependencies.serde_json]
+version = "1"