summaryrefslogtreecommitdiffstats
path: root/vendor/spki/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/spki/Cargo.toml')
-rw-r--r--vendor/spki/Cargo.toml77
1 files changed, 77 insertions, 0 deletions
diff --git a/vendor/spki/Cargo.toml b/vendor/spki/Cargo.toml
new file mode 100644
index 000000000..13205cb43
--- /dev/null
+++ b/vendor/spki/Cargo.toml
@@ -0,0 +1,77 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+rust-version = "1.57"
+name = "spki"
+version = "0.6.0"
+authors = ["RustCrypto Developers"]
+description = """
+X.509 Subject Public Key Info (RFC5280) describing public keys as well as their
+associated AlgorithmIdentifiers (i.e. OIDs)
+"""
+readme = "README.md"
+keywords = [
+ "crypto",
+ "x509",
+]
+categories = [
+ "cryptography",
+ "data-structures",
+ "encoding",
+ "no-std",
+]
+license = "Apache-2.0 OR MIT"
+repository = "https://github.com/RustCrypto/formats/tree/master/spki"
+resolver = "2"
+
+[package.metadata.docs.rs]
+all-features = true
+rustdoc-args = [
+ "--cfg",
+ "docsrs",
+]
+
+[dependencies.base64ct]
+version = "1"
+optional = true
+default-features = false
+
+[dependencies.der]
+version = "0.6"
+features = ["oid"]
+
+[dependencies.sha2]
+version = "0.10"
+optional = true
+default-features = false
+
+[dev-dependencies.hex-literal]
+version = "0.3"
+
+[dev-dependencies.tempfile]
+version = "3"
+
+[features]
+alloc = [
+ "base64ct/alloc",
+ "der/alloc",
+]
+fingerprint = ["sha2"]
+pem = [
+ "alloc",
+ "der/pem",
+]
+std = [
+ "der/std",
+ "alloc",
+]