summaryrefslogtreecommitdiffstats
path: root/vendor/stable_deref_trait/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/stable_deref_trait/Cargo.toml')
-rw-r--r--vendor/stable_deref_trait/Cargo.toml27
1 files changed, 27 insertions, 0 deletions
diff --git a/vendor/stable_deref_trait/Cargo.toml b/vendor/stable_deref_trait/Cargo.toml
new file mode 100644
index 000000000..6bc26c3d3
--- /dev/null
+++ b/vendor/stable_deref_trait/Cargo.toml
@@ -0,0 +1,27 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+name = "stable_deref_trait"
+version = "1.2.0"
+authors = ["Robert Grosse <n210241048576@gmail.com>"]
+description = "An unsafe marker trait for types like Box and Rc that dereference to a stable address even when moved, and hence can be used with libraries such as owning_ref and rental.\n"
+documentation = "https://docs.rs/stable_deref_trait/1.2.0/stable_deref_trait"
+readme = "README.md"
+categories = ["memory-management", "no-std"]
+license = "MIT/Apache-2.0"
+repository = "https://github.com/storyyeller/stable_deref_trait"
+
+[features]
+alloc = []
+default = ["std"]
+std = ["alloc"]