summaryrefslogtreecommitdiffstats
path: root/vendor/string_cache/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/string_cache/Cargo.toml')
-rw-r--r--vendor/string_cache/Cargo.toml50
1 files changed, 50 insertions, 0 deletions
diff --git a/vendor/string_cache/Cargo.toml b/vendor/string_cache/Cargo.toml
new file mode 100644
index 000000000..f5f17fa9f
--- /dev/null
+++ b/vendor/string_cache/Cargo.toml
@@ -0,0 +1,50 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "string_cache"
+version = "0.8.3"
+authors = ["The Servo Project Developers"]
+description = "A string interning library for Rust, developed as part of the Servo project."
+documentation = "https://docs.rs/string_cache/"
+license = "MIT / Apache-2.0"
+repository = "https://github.com/servo/string-cache"
+
+[lib]
+name = "string_cache"
+
+[[test]]
+name = "small-stack"
+harness = false
+
+[dependencies.lazy_static]
+version = "1.1.0"
+
+[dependencies.new_debug_unreachable]
+version = "1.0.2"
+
+[dependencies.parking_lot]
+version = "0.11"
+
+[dependencies.phf_shared]
+version = "0.10"
+
+[dependencies.precomputed-hash]
+version = "0.1"
+
+[dependencies.serde]
+version = "1"
+optional = true
+
+[features]
+default = ["serde_support"]
+serde_support = ["serde"]