summaryrefslogtreecommitdiffstats
path: root/vendor/strum_macros/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/strum_macros/Cargo.toml')
-rw-r--r--vendor/strum_macros/Cargo.toml58
1 files changed, 58 insertions, 0 deletions
diff --git a/vendor/strum_macros/Cargo.toml b/vendor/strum_macros/Cargo.toml
new file mode 100644
index 000000000..f35110d1e
--- /dev/null
+++ b/vendor/strum_macros/Cargo.toml
@@ -0,0 +1,58 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "strum_macros"
+version = "0.24.3"
+authors = ["Peter Glotfelty <peter.glotfelty@microsoft.com>"]
+description = "Helpful macros for working with enums and strings"
+homepage = "https://github.com/Peternator7/strum"
+documentation = "https://docs.rs/strum"
+readme = "README.md"
+keywords = [
+ "enum",
+ "string",
+ "macros",
+ "proc-macros",
+]
+categories = [
+ "development-tools::procedural-macro-helpers",
+ "parsing",
+]
+license = "MIT"
+repository = "https://github.com/Peternator7/strum"
+
+[lib]
+name = "strum_macros"
+proc-macro = true
+
+[dependencies.heck]
+version = "0.4"
+
+[dependencies.proc-macro2]
+version = "1.0"
+
+[dependencies.quote]
+version = "1.0"
+
+[dependencies.rustversion]
+version = "1.0"
+
+[dependencies.syn]
+version = "1.0"
+features = [
+ "parsing",
+ "extra-traits",
+]
+
+[dev-dependencies.strum]
+version = "0.24"