summaryrefslogtreecommitdiffstats
path: root/vendor/tar/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/tar/Cargo.toml')
-rw-r--r--vendor/tar/Cargo.toml37
1 files changed, 37 insertions, 0 deletions
diff --git a/vendor/tar/Cargo.toml b/vendor/tar/Cargo.toml
new file mode 100644
index 000000000..23771b564
--- /dev/null
+++ b/vendor/tar/Cargo.toml
@@ -0,0 +1,37 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "tar"
+version = "0.4.38"
+authors = ["Alex Crichton <alex@alexcrichton.com>"]
+exclude = ["tests/archives/*"]
+description = "A Rust implementation of a TAR file reader and writer. This library does not\ncurrently handle compression, but it is abstract over all I/O readers and\nwriters. Additionally, great lengths are taken to ensure that the entire\ncontents are never required to be entirely resident in memory all at once.\n"
+homepage = "https://github.com/alexcrichton/tar-rs"
+documentation = "https://docs.rs/tar"
+readme = "README.md"
+keywords = ["tar", "tarfile", "encoding"]
+license = "MIT/Apache-2.0"
+repository = "https://github.com/alexcrichton/tar-rs"
+[dependencies.filetime]
+version = "0.2.8"
+[dev-dependencies.tempfile]
+version = "3"
+
+[features]
+default = ["xattr"]
+[target."cfg(unix)".dependencies.libc]
+version = "0.2"
+
+[target."cfg(unix)".dependencies.xattr]
+version = "0.2"
+optional = true