summaryrefslogtreecommitdiffstats
path: root/vendor/terminal_size/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/terminal_size/Cargo.toml')
-rw-r--r--vendor/terminal_size/Cargo.toml39
1 files changed, 39 insertions, 0 deletions
diff --git a/vendor/terminal_size/Cargo.toml b/vendor/terminal_size/Cargo.toml
new file mode 100644
index 000000000..8c729460f
--- /dev/null
+++ b/vendor/terminal_size/Cargo.toml
@@ -0,0 +1,39 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "terminal_size"
+version = "0.2.3"
+authors = ["Andrew Chin <achin@eminence32.net>"]
+description = "Gets the size of your Linux or Windows terminal"
+documentation = "https://docs.rs/crate/terminal_size"
+readme = "README.md"
+keywords = [
+ "terminal",
+ "console",
+ "term",
+ "size",
+ "dimensions",
+]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/eminence/terminal-size"
+
+[target."cfg(not(windows))".dependencies.rustix]
+version = "0.36.3"
+features = ["termios"]
+
+[target."cfg(windows)".dependencies.windows-sys]
+version = "0.42.0"
+features = [
+ "Win32_Foundation",
+ "Win32_System_Console",
+]