summaryrefslogtreecommitdiffstats
path: root/vendor/termize/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--vendor/termize/Cargo.toml56
1 files changed, 56 insertions, 0 deletions
diff --git a/vendor/termize/Cargo.toml b/vendor/termize/Cargo.toml
new file mode 100644
index 000000000..d248f4db5
--- /dev/null
+++ b/vendor/termize/Cargo.toml
@@ -0,0 +1,56 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "termize"
+version = "0.1.1"
+authors = ["Yuki Okushi <huyuumi.dev@gmail.com>"]
+exclude = [".github/*", ".travis.yml", ".cirrus.yml"]
+description = "functions for determining terminal sizes and dimensions"
+documentation = "https://docs.rs/termize"
+readme = "README.md"
+keywords = ["term", "terminal", "size", "width", "dimension"]
+categories = ["command-line-interface"]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/JohnTitor/termize"
+[profile.dev]
+opt-level = 0
+lto = false
+codegen-units = 4
+debug = true
+debug-assertions = true
+rpath = false
+
+[profile.release]
+opt-level = 3
+lto = true
+debug = false
+debug-assertions = false
+rpath = false
+
+[profile.test]
+opt-level = 1
+lto = false
+codegen-units = 2
+debug = true
+debug-assertions = true
+rpath = false
+
+[dependencies]
+[target."cfg(unix)".dependencies.libc]
+version = "0.2.66"
+[target."cfg(windows)".dependencies.winapi]
+version = "0.3.8"
+features = ["handleapi", "processenv", "wincon", "winbase"]
+[badges.cirrus-ci]
+repository = "JohnTitor/termize"