summaryrefslogtreecommitdiffstats
path: root/vendor/thorin-dwp
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/thorin-dwp')
-rw-r--r--vendor/thorin-dwp/.cargo-checksum.json2
-rw-r--r--vendor/thorin-dwp/Cargo.toml5
-rw-r--r--vendor/thorin-dwp/README.md2
3 files changed, 5 insertions, 4 deletions
diff --git a/vendor/thorin-dwp/.cargo-checksum.json b/vendor/thorin-dwp/.cargo-checksum.json
index e2eb4cd0a..1cbdb54a1 100644
--- a/vendor/thorin-dwp/.cargo-checksum.json
+++ b/vendor/thorin-dwp/.cargo-checksum.json
@@ -1 +1 @@
-{"files":{"Cargo.toml":"7c5e6da3d5ae9e5c99bcbff6d7119760f23f657370ab8e6ed7dff352ccc3ea3b","README.md":"5fa7f35fc892abed89ac77d472cc746f61e2c8c2d56678ab797b4ef45cb12fa0","src/error.rs":"7eccbcddfc8694392e7c79e5346c95feb1ea7bd8818de4f59316533cb801518a","src/ext.rs":"a385d1fd8f2102c66a8d5986a2899189a1139683cf6267f63978074867e9a18a","src/index.rs":"060c5c5453e9ec9f2641d4b9d1e8b32dfaf9025510b8fa8d531dd3578640b2d1","src/lib.rs":"e23d466e66b1c959832569ea17c791aafe92b1bebd32bb1d1c59dca173b87d8e","src/package.rs":"43cf081749d232baf60a65a65478e68fc708d8bf308a5b29bd24cfa4120a7ebc","src/relocate.rs":"6a9d7e123bb6d0934847209a1192ed2a23a0502d32a1ccfceccf40726f469618","src/strings.rs":"fb85d8650bccd843bcf5145d8b06a1beec1332eb2b4f7aef9a09f88172ba2688"},"package":"e6cb0c7868d7f90407531108ab03263d9452a8811b7cdd87675343a40d4aa254"} \ No newline at end of file
+{"files":{"Cargo.toml":"989f60194ba1f0f9b1862bf0b264f466c45794ba39c6443bea09a8bcbedaec2c","README.md":"791a75e565f7cb2effc72408cfc2d6ccb0b54c3385115b342345594f3e5fb6d2","src/error.rs":"7eccbcddfc8694392e7c79e5346c95feb1ea7bd8818de4f59316533cb801518a","src/ext.rs":"a385d1fd8f2102c66a8d5986a2899189a1139683cf6267f63978074867e9a18a","src/index.rs":"060c5c5453e9ec9f2641d4b9d1e8b32dfaf9025510b8fa8d531dd3578640b2d1","src/lib.rs":"e23d466e66b1c959832569ea17c791aafe92b1bebd32bb1d1c59dca173b87d8e","src/package.rs":"43cf081749d232baf60a65a65478e68fc708d8bf308a5b29bd24cfa4120a7ebc","src/relocate.rs":"6a9d7e123bb6d0934847209a1192ed2a23a0502d32a1ccfceccf40726f469618","src/strings.rs":"fb85d8650bccd843bcf5145d8b06a1beec1332eb2b4f7aef9a09f88172ba2688"},"package":"da8fbf660a019b6bf11ea95762041464aa9099cc293b6a66d77cea5107619671"} \ No newline at end of file
diff --git a/vendor/thorin-dwp/Cargo.toml b/vendor/thorin-dwp/Cargo.toml
index b39fadbbf..3635bcd50 100644
--- a/vendor/thorin-dwp/Cargo.toml
+++ b/vendor/thorin-dwp/Cargo.toml
@@ -12,7 +12,7 @@
[package]
edition = "2021"
name = "thorin-dwp"
-version = "0.3.0"
+version = "0.4.0"
authors = ["David Wood <david.wood@huawei.com>"]
description = "Library for building DWARF packages from input DWARF objects and packages"
homepage = "https://docs.rs/thorin-dwp"
@@ -27,6 +27,7 @@ keywords = [
categories = ["development-tools::debugging"]
license = "MIT OR Apache-2.0"
repository = "https://github.com/rust-lang/thorin"
+resolver = "1"
[lib]
name = "thorin"
@@ -45,7 +46,7 @@ default-features = false
version = "0.12.0"
[dependencies.object]
-version = "0.29.0"
+version = "0.30.0"
features = [
"archive",
"read",
diff --git a/vendor/thorin-dwp/README.md b/vendor/thorin-dwp/README.md
index 3735e3efa..ae3b8099c 100644
--- a/vendor/thorin-dwp/README.md
+++ b/vendor/thorin-dwp/README.md
@@ -12,7 +12,7 @@ cross-crate Split DWARF packaging in `rustc`.
To use `thorin` in your own project, add it to your `Cargo.toml`:
```toml
-thorin-dwp = "0.3.0"
+thorin-dwp = "0.4.0"
```
See the [`thorin-bin`](../thorin-bin/README.md) crate for an example of using `thorin`'s library