summaryrefslogtreecommitdiffstats
path: root/vendor/time/README.md
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/time/README.md')
-rw-r--r--vendor/time/README.md53
1 files changed, 32 insertions, 21 deletions
diff --git a/vendor/time/README.md b/vendor/time/README.md
index f427eb3ea..34b575340 100644
--- a/vendor/time/README.md
+++ b/vendor/time/README.md
@@ -1,31 +1,42 @@
-time
-====
+# time
-Utilities for working with time-related functions in Rust
+[![minimum rustc: 1.60](https://img.shields.io/badge/minimum%20rustc-1.60-yellowgreen?logo=rust&style=flat-square)](https://www.whatrustisit.com)
+[![version](https://img.shields.io/crates/v/time?color=blue&logo=rust&style=flat-square)](https://crates.io/crates/time)
+[![build status](https://img.shields.io/github/workflow/status/time-rs/time/Build/main?style=flat-square)](https://github.com/time-rs/time/actions)
+[![codecov](https://codecov.io/gh/time-rs/time/branch/main/graph/badge.svg?token=yt4XSmQNKQ)](https://codecov.io/gh/time-rs/time)
-[![build status](https://github.com/time-rs/time/workflows/Build/badge.svg?branch=v0.1)](https://github.com/time-rs/time/actions?query=branch%3Av0.1)
-[![Documentation](https://docs.rs/time/badge.svg?version=0.1)](https://docs.rs/time/~0.1)
-![rustc 1.21.0](https://img.shields.io/badge/rustc-1.21.0-blue)
+Documentation:
-## time v0.1.x is Deprecated
+- [latest release](https://docs.rs/time)
+- [main branch](https://time-rs.github.io/api/time)
+- [book](https://time-rs.github.io/book)
-The 0.1.x series of this library is deprecated and in maintenance mode. No new
-features will be added. Active development now occurs in the 0.2.x series.
+## Minimum Rust version policy
-If you need additional functionality that this crate does not provide, check
-out the [`chrono`](https://github.com/chronotope/chrono) crate.
+The time crate is guaranteed to compile with any release of rustc from the past six months.
+Optional feature flags that enable interoperability with third-party crates (e.g. rand)
+follow the policy of that crate if stricter.
-## Usage
+## Contributing
-Put this in your `Cargo.toml`:
+Contributions are always welcome! If you have an idea, it's best to float it by me before working on
+it to ensure no effort is wasted. If there's already an open issue for it, knock yourself out.
+Internal documentation can be viewed [here](https://time-rs.github.io/internal-api/time).
-```toml
-[dependencies]
-time = "0.1"
-```
+If you have any questions, feel free to use [Discussions]. Don't hesitate to ask questions — that's
+what I'm here for!
-And this in your crate root:
+[Discussions]: https://github.com/time-rs/time/discussions
-```rust
-extern crate time;
-```
+## License
+
+This project is licensed under either of
+
+- [Apache License, Version 2.0](https://github.com/time-rs/time/blob/main/LICENSE-Apache)
+- [MIT license](https://github.com/time-rs/time/blob/main/LICENSE-MIT)
+
+at your option.
+
+Unless you explicitly state otherwise, any contribution intentionally submitted for inclusion in
+time by you, as defined in the Apache-2.0 license, shall be dual licensed as above, without any
+additional terms or conditions.