summaryrefslogtreecommitdiffstats
path: root/vendor/topological-sort/README.md
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/topological-sort/README.md')
-rw-r--r--vendor/topological-sort/README.md28
1 files changed, 17 insertions, 11 deletions
diff --git a/vendor/topological-sort/README.md b/vendor/topological-sort/README.md
index 87dd7bea5..d20cc360f 100644
--- a/vendor/topological-sort/README.md
+++ b/vendor/topological-sort/README.md
@@ -1,12 +1,16 @@
# topological-sort-rs
-[![Build Status](https://travis-ci.org/gifnksm/topological-sort-rs.svg)](https://travis-ci.org/gifnksm/topological-sort-rs)
-[![Coverage Status](https://coveralls.io/repos/gifnksm/topological-sort-rs/badge.svg?branch=master&service=github)](https://coveralls.io/github/gifnksm/topological-sort-rs?branch=master)
-[![crates.io](http://meritbadge.herokuapp.com/topological-sort)](https://crates.io/crates/topological-sort)
+[![maintenance status: passively-maintained](https://img.shields.io/badge/maintenance-passively--maintained-yellowgreen.svg)](https://doc.rust-lang.org/cargo/reference/manifest.html#the-badges-section)
+[![license](https://img.shields.io/crates/l/topological-sort.svg)](#license)
+[![crates.io](https://img.shields.io/crates/v/topological-sort.svg)](https://crates.io/crates/topological-sort)
+[![docs.rs](https://img.shields.io/docsrs/topological-sort/latest)](https://docs.rs/topological-sort/latest/)
+[![rust 1.43.1+ badge](https://img.shields.io/badge/rust-1.43.1+-93450a.svg)](https://doc.rust-lang.org/cargo/reference/manifest.html#the-rust-version-field)
+[![Rust CI](https://github.com/gifnksm/topological-sort-rs/actions/workflows/rust-ci.yml/badge.svg)](https://github.com/gifnksm/topological-sort-rs/actions/workflows/rust-ci.yml)
+[![Codecov](https://codecov.io/gh/gifnksm/topological-sort-rs/branch/master/graph/badge.svg?token=VreVOoM3Yb)](https://codecov.io/gh/gifnksm/topological-sort-rs)
Performs topological sorting.
-[Documentation](https://docs.rs/topological-sort/~0.0)
+[Documentation](https://docs.rs/topological-sort)
## How to use?
@@ -14,21 +18,23 @@ Add this to your `Cargo.toml`:
```toml
[dependencies]
-topological-sort = "0.0"
+topological-sort = "0.2.2"
```
-and this to your crate root:
+## Minimum supported Rust version (MSRV)
-```rust
-extern crate topological_sort;
-```
+The minimum supported Rust version is **Rust 1.43.1**.
+At least the last 3 versions of stable Rust are supported at any given time.
+
+While a crate is pre-release status (0.x.x) it may have its MSRV bumped in a patch release.
+Once a crate has reached 1.x, any MSRV bump will be accompanied with a new minor version.
## License
Licensed under either of
- * Apache License, Version 2.0, ([LICENSE-APACHE](LICENSE-APACHE) or http://www.apache.org/licenses/LICENSE-2.0)
- * MIT license ([LICENSE-MIT](LICENSE-MIT) or http://opensource.org/licenses/MIT)
+* Apache License, Version 2.0, ([LICENSE-APACHE](LICENSE-APACHE) or <https://www.apache.org/licenses/LICENSE-2.0>)
+* MIT license ([LICENSE-MIT](LICENSE-MIT) or <https://opensource.org/licenses/MIT>)
at your option.