summaryrefslogtreecommitdiffstats
path: root/vendor/tracing-subscriber-0.3.3/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--vendor/tracing-subscriber-0.3.3/Cargo.toml (renamed from vendor/tracing-subscriber/Cargo.toml)138
1 files changed, 28 insertions, 110 deletions
diff --git a/vendor/tracing-subscriber/Cargo.toml b/vendor/tracing-subscriber-0.3.3/Cargo.toml
index dd432c4ac..b5e7ba7db 100644
--- a/vendor/tracing-subscriber/Cargo.toml
+++ b/vendor/tracing-subscriber-0.3.3/Cargo.toml
@@ -11,39 +11,20 @@
[package]
edition = "2018"
-rust-version = "1.49.0"
+rust-version = "1.42.0"
name = "tracing-subscriber"
-version = "0.3.15"
-authors = [
- "Eliza Weisman <eliza@buoyant.io>",
- "David Barsky <me@davidbarsky.com>",
- "Tokio Contributors <team@tokio.rs>",
-]
-description = """
-Utilities for implementing and composing `tracing` subscribers.
-"""
+version = "0.3.3"
+authors = ["Eliza Weisman <eliza@buoyant.io>", "David Barsky <me@davidbarsky.com>", "Tokio Contributors <team@tokio.rs>"]
+description = "Utilities for implementing and composing `tracing` subscribers.\n"
homepage = "https://tokio.rs"
readme = "README.md"
-keywords = [
- "logging",
- "tracing",
- "metrics",
- "subscriber",
-]
-categories = [
- "development-tools::debugging",
- "development-tools::profiling",
- "asynchronous",
-]
+keywords = ["logging", "tracing", "metrics", "subscriber"]
+categories = ["development-tools::debugging", "development-tools::profiling", "asynchronous"]
license = "MIT"
repository = "https://github.com/tokio-rs/tracing"
-
[package.metadata.docs.rs]
all-features = true
-rustdoc-args = [
- "--cfg",
- "docsrs",
-]
+rustdoc-args = ["--cfg", "docsrs"]
[[bench]]
name = "filter"
@@ -60,21 +41,20 @@ harness = false
[[bench]]
name = "enter"
harness = false
-
[dependencies.ansi_term]
version = "0.12"
optional = true
-[dependencies.matchers]
-version = "0.1.0"
+[dependencies.lazy_static]
+version = "1"
optional = true
-[dependencies.once_cell]
-version = "1.12"
+[dependencies.matchers]
+version = "0.1.0"
optional = true
[dependencies.parking_lot]
-version = "0.12"
+version = ">= 0.7, <= 0.11"
optional = true
[dependencies.regex]
@@ -96,11 +76,11 @@ version = "0.1.0"
optional = true
[dependencies.smallvec]
-version = "1.2.0"
+version = "1"
optional = true
[dependencies.thread_local]
-version = "1.1.4"
+version = "1.0.1"
optional = true
[dependencies.time]
@@ -114,22 +94,17 @@ optional = true
default-features = false
[dependencies.tracing-core]
-version = "0.1.28"
-default-features = false
+version = "0.1.20"
[dependencies.tracing-log]
version = "0.1.2"
-features = [
- "log-tracer",
- "std",
-]
+features = ["log-tracer", "std"]
optional = true
default-features = false
[dependencies.tracing-serde]
-version = "0.1.3"
+version = "0.1.2"
optional = true
-
[dev-dependencies.criterion]
version = "0.3"
default_features = false
@@ -144,27 +119,18 @@ default-features = false
[dev-dependencies.time]
version = "0.3"
-features = [
- "formatting",
- "macros",
-]
+features = ["formatting", "macros"]
[dev-dependencies.tokio]
-version = "1"
-features = [
- "rt",
- "macros",
-]
+version = "0.2"
+features = ["rt-core", "macros"]
[dev-dependencies.tracing]
version = "0.1"
[dev-dependencies.tracing-futures]
version = "0.2"
-features = [
- "std-future",
- "std",
-]
+features = ["std-future", "std"]
default-features = false
[dev-dependencies.tracing-log]
@@ -172,61 +138,13 @@ version = "0.1.2"
[features]
alloc = []
-ansi = [
- "fmt",
- "ansi_term",
-]
-default = [
- "smallvec",
- "fmt",
- "ansi",
- "tracing-log",
- "std",
-]
-env-filter = [
- "matchers",
- "regex",
- "once_cell",
- "tracing",
- "std",
- "thread_local",
-]
-fmt = [
- "registry",
- "std",
-]
-json = [
- "tracing-serde",
- "serde",
- "serde_json",
-]
+ansi = ["fmt", "ansi_term"]
+default = ["smallvec", "fmt", "ansi", "tracing-log", "std"]
+env-filter = ["matchers", "regex", "lazy_static", "tracing", "std"]
+fmt = ["registry", "std"]
+json = ["tracing-serde", "serde", "serde_json"]
local-time = ["time/local-offset"]
-registry = [
- "sharded-slab",
- "thread_local",
- "std",
-]
-std = [
- "alloc",
- "tracing-core/std",
-]
-valuable = [
- "tracing-core/valuable",
- "valuable_crate",
- "valuable-serde",
- "tracing-serde/valuable",
-]
-
-[target."cfg(tracing_unstable)".dependencies.valuable-serde]
-version = "0.1.0"
-optional = true
-default_features = false
-
-[target."cfg(tracing_unstable)".dependencies.valuable_crate]
-version = "0.1.0"
-optional = true
-default_features = false
-package = "valuable"
-
+registry = ["sharded-slab", "thread_local", "std"]
+std = ["alloc", "tracing-core/std"]
[badges.maintenance]
status = "experimental"