summaryrefslogtreecommitdiffstats
path: root/vendor/tracing-subscriber/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--vendor/tracing-subscriber/Cargo.toml232
1 files changed, 0 insertions, 232 deletions
diff --git a/vendor/tracing-subscriber/Cargo.toml b/vendor/tracing-subscriber/Cargo.toml
deleted file mode 100644
index 1d15642a2..000000000
--- a/vendor/tracing-subscriber/Cargo.toml
+++ /dev/null
@@ -1,232 +0,0 @@
-# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
-#
-# When uploading crates to the registry Cargo will automatically
-# "normalize" Cargo.toml files for maximal compatibility
-# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies.
-#
-# If you are reading this file be aware that the original Cargo.toml
-# will likely look very different (and much more reasonable).
-# See Cargo.toml.orig for the original contents.
-
-[package]
-edition = "2018"
-rust-version = "1.49.0"
-name = "tracing-subscriber"
-version = "0.3.14"
-authors = [
- "Eliza Weisman <eliza@buoyant.io>",
- "David Barsky <me@davidbarsky.com>",
- "Tokio Contributors <team@tokio.rs>",
-]
-description = """
-Utilities for implementing and composing `tracing` subscribers.
-"""
-homepage = "https://tokio.rs"
-readme = "README.md"
-keywords = [
- "logging",
- "tracing",
- "metrics",
- "subscriber",
-]
-categories = [
- "development-tools::debugging",
- "development-tools::profiling",
- "asynchronous",
-]
-license = "MIT"
-repository = "https://github.com/tokio-rs/tracing"
-
-[package.metadata.docs.rs]
-all-features = true
-rustdoc-args = [
- "--cfg",
- "docsrs",
-]
-
-[[bench]]
-name = "filter"
-harness = false
-
-[[bench]]
-name = "filter_log"
-harness = false
-
-[[bench]]
-name = "fmt"
-harness = false
-
-[[bench]]
-name = "enter"
-harness = false
-
-[dependencies.ansi_term]
-version = "0.12"
-optional = true
-
-[dependencies.matchers]
-version = "0.1.0"
-optional = true
-
-[dependencies.once_cell]
-version = "1.12"
-optional = true
-
-[dependencies.parking_lot]
-version = "0.12"
-optional = true
-
-[dependencies.regex]
-version = "1"
-features = ["std"]
-optional = true
-default-features = false
-
-[dependencies.serde]
-version = "1.0"
-optional = true
-
-[dependencies.serde_json]
-version = "1.0"
-optional = true
-
-[dependencies.sharded-slab]
-version = "0.1.0"
-optional = true
-
-[dependencies.smallvec]
-version = "1.2.0"
-optional = true
-
-[dependencies.thread_local]
-version = "1.1.4"
-optional = true
-
-[dependencies.time]
-version = "0.3"
-features = ["formatting"]
-optional = true
-
-[dependencies.tracing]
-version = "0.1"
-optional = true
-default-features = false
-
-[dependencies.tracing-core]
-version = "0.1.28"
-default-features = false
-
-[dependencies.tracing-log]
-version = "0.1.2"
-features = [
- "log-tracer",
- "std",
-]
-optional = true
-default-features = false
-
-[dependencies.tracing-serde]
-version = "0.1.3"
-optional = true
-
-[dev-dependencies.criterion]
-version = "0.3"
-default_features = false
-
-[dev-dependencies.log]
-version = "0.4"
-
-[dev-dependencies.regex]
-version = "1"
-features = ["std"]
-default-features = false
-
-[dev-dependencies.time]
-version = "0.3"
-features = [
- "formatting",
- "macros",
-]
-
-[dev-dependencies.tokio]
-version = "1"
-features = [
- "rt",
- "macros",
-]
-
-[dev-dependencies.tracing]
-version = "0.1"
-
-[dev-dependencies.tracing-futures]
-version = "0.2"
-features = [
- "std-future",
- "std",
-]
-default-features = false
-
-[dev-dependencies.tracing-log]
-version = "0.1.2"
-
-[features]
-alloc = []
-ansi = [
- "fmt",
- "ansi_term",
-]
-default = [
- "smallvec",
- "fmt",
- "ansi",
- "tracing-log",
- "std",
-]
-env-filter = [
- "matchers",
- "regex",
- "once_cell",
- "tracing",
- "std",
- "thread_local",
-]
-fmt = [
- "registry",
- "std",
-]
-json = [
- "tracing-serde",
- "serde",
- "serde_json",
-]
-local-time = ["time/local-offset"]
-registry = [
- "sharded-slab",
- "thread_local",
- "std",
-]
-std = [
- "alloc",
- "tracing-core/std",
-]
-valuable = [
- "tracing-core/valuable",
- "valuable_crate",
- "valuable-serde",
- "tracing-serde/valuable",
-]
-
-[target."cfg(tracing_unstable)".dependencies.valuable-serde]
-version = "0.1.0"
-optional = true
-default_features = false
-
-[target."cfg(tracing_unstable)".dependencies.valuable_crate]
-version = "0.1.0"
-optional = true
-default_features = false
-package = "valuable"
-
-[badges.maintenance]
-status = "experimental"