summaryrefslogtreecommitdiffstats
path: root/vendor/twox-hash/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/twox-hash/Cargo.toml')
-rw-r--r--vendor/twox-hash/Cargo.toml71
1 files changed, 71 insertions, 0 deletions
diff --git a/vendor/twox-hash/Cargo.toml b/vendor/twox-hash/Cargo.toml
new file mode 100644
index 000000000..16aa1f4d7
--- /dev/null
+++ b/vendor/twox-hash/Cargo.toml
@@ -0,0 +1,71 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "twox-hash"
+version = "1.6.3"
+authors = ["Jake Goulding <jake.goulding@gmail.com>"]
+description = "A Rust implementation of the XXHash and XXH3 algorithms"
+documentation = "https://docs.rs/twox-hash/"
+readme = "README.md"
+keywords = [
+ "hash",
+ "hasher",
+ "xxhash",
+ "xxh3",
+]
+categories = ["algorithms"]
+license = "MIT"
+repository = "https://github.com/shepmaster/twox-hash"
+
+[dependencies.cfg-if]
+version = ">= 0.1, < 2"
+default-features = false
+
+[dependencies.digest]
+version = "0.8"
+optional = true
+default-features = false
+package = "digest"
+
+[dependencies.digest_0_10]
+version = "0.10"
+optional = true
+default-features = false
+package = "digest"
+
+[dependencies.digest_0_9]
+version = "0.9"
+optional = true
+default-features = false
+package = "digest"
+
+[dependencies.rand]
+version = ">= 0.3.10, < 0.9"
+optional = true
+
+[dependencies.serde]
+version = "1.0"
+features = ["derive"]
+optional = true
+
+[dependencies.static_assertions]
+version = "1.0"
+default-features = false
+
+[dev-dependencies.serde_json]
+version = "1.0"
+
+[features]
+default = ["std"]
+serialize = ["serde"]
+std = ["rand"]