summaryrefslogtreecommitdiffstats
path: root/vendor/ui_test/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/ui_test/shell.nix')
-rw-r--r--vendor/ui_test/shell.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/vendor/ui_test/shell.nix b/vendor/ui_test/shell.nix
new file mode 100644
index 000000000..8511dcca9
--- /dev/null
+++ b/vendor/ui_test/shell.nix
@@ -0,0 +1,18 @@
+let
+ pkgs = import <nixpkgs> {};
+in
+pkgs.mkShell rec {
+ name = "rustc";
+ buildInputs = with pkgs; [
+ rustup
+ pkg-config
+ alsaLib
+ libGL
+ xorg.libX11
+ xorg.libXi
+ python39
+ ];
+ RUST_SRC_PATH = "${pkgs.rust.packages.stable.rustPlatform.rustLibSrc}";
+ LD_LIBRARY_PATH = "${pkgs.lib.makeLibraryPath buildInputs}";
+}
+