summaryrefslogtreecommitdiffstats
path: root/vendor/unic-ucd-version
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/unic-ucd-version')
-rw-r--r--vendor/unic-ucd-version/.cargo-checksum.json1
-rw-r--r--vendor/unic-ucd-version/Cargo.toml42
-rw-r--r--vendor/unic-ucd-version/src/lib.rs32
-rw-r--r--vendor/unic-ucd-version/src/pkg_info.rs20
-rw-r--r--vendor/unic-ucd-version/src/unicode_version.rs29
-rw-r--r--vendor/unic-ucd-version/tables/unicode_version.rsv3
-rw-r--r--vendor/unic-ucd-version/tests/basic_tests.rs26
7 files changed, 0 insertions, 153 deletions
diff --git a/vendor/unic-ucd-version/.cargo-checksum.json b/vendor/unic-ucd-version/.cargo-checksum.json
deleted file mode 100644
index ff13a3a98..000000000
--- a/vendor/unic-ucd-version/.cargo-checksum.json
+++ /dev/null
@@ -1 +0,0 @@
-{"files":{"Cargo.toml":"75628c37e215f72578113d96f746acba57b8a2f3448675a2f2a807f0930d4ce7","src/lib.rs":"51d52da8220e430f32523aa5972708e698fca29fea8b64a4cbdc67d3d1830f37","src/pkg_info.rs":"37cbe4efd0b0205d251e1ef7714b23e3be27052c8a0de6b1ae3cbf3aefae1fe5","src/unicode_version.rs":"bc2fe0341c2a60909f1ef7e56593b836344ca4b4ae8f73e7f7aa07259963dd03","tables/unicode_version.rsv":"a2efcb89606ee821ff9ac5595e5126a65f2b00b70ca1054c1884f741827ab230","tests/basic_tests.rs":"8d3597a7c3365b5516a2e6200386b5e8dac836aa6f90b8a329ff120f0c54f207"},"package":"96bd2f2237fe450fcd0a1d2f5f4e91711124f7857ba2e964247776ebeeb7b0c4"} \ No newline at end of file
diff --git a/vendor/unic-ucd-version/Cargo.toml b/vendor/unic-ucd-version/Cargo.toml
deleted file mode 100644
index c6328141c..000000000
--- a/vendor/unic-ucd-version/Cargo.toml
+++ /dev/null
@@ -1,42 +0,0 @@
-# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
-#
-# When uploading crates to the registry Cargo will automatically
-# "normalize" Cargo.toml files for maximal compatibility
-# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g. crates.io) dependencies
-#
-# If you believe there's an error in this file please file an
-# issue against the rust-lang/cargo repository. If you're
-# editing this file be aware that the upstream Cargo.toml
-# will likely look very different (and much more reasonable)
-
-[package]
-edition = "2018"
-name = "unic-ucd-version"
-version = "0.9.0"
-authors = ["The UNIC Project Developers"]
-exclude = []
-description = "UNIC — Unicode Character Database — Version"
-keywords = ["text", "unicode", "version"]
-categories = ["internationalization", "text-processing", "parsing", "rendering"]
-license = "MIT/Apache-2.0"
-repository = "https://github.com/open-i18n/rust-unic/"
-[dependencies.unic-common]
-version = "0.9.0"
-[badges.appveyor]
-branch = "master"
-repository = "open-i18n/rust-unic"
-service = "github"
-
-[badges.is-it-maintained-issue-resolution]
-repository = "open-i18n/rust-unic"
-
-[badges.is-it-maintained-open-issues]
-repository = "open-i18n/rust-unic"
-
-[badges.maintenance]
-status = "actively-developed"
-
-[badges.travis-ci]
-branch = "master"
-repository = "open-i18n/rust-unic"
diff --git a/vendor/unic-ucd-version/src/lib.rs b/vendor/unic-ucd-version/src/lib.rs
deleted file mode 100644
index 3877f04d7..000000000
--- a/vendor/unic-ucd-version/src/lib.rs
+++ /dev/null
@@ -1,32 +0,0 @@
-// Copyright 2017 The UNIC Project Developers.
-//
-// See the COPYRIGHT file at the top-level directory of this distribution.
-//
-// Licensed under the Apache License, Version 2.0 <LICENSE-APACHE or
-// http://www.apache.org/licenses/LICENSE-2.0> or the MIT license
-// <LICENSE-MIT or http://opensource.org/licenses/MIT>, at your
-// option. This file may not be copied, modified, or distributed
-// except according to those terms.
-
-#![no_std]
-#![warn(
- bad_style,
- missing_debug_implementations,
- missing_docs,
- unconditional_recursion
-)]
-#![forbid(unsafe_code)]
-
-//! # UNIC — UCD — Core
-//!
-//! A component of [`unic`: Unicode and Internationalization Crates for Rust](/unic/).
-//!
-//! Core create indicating the version of Unicode Character Database.
-
-pub use unic_common::version::UnicodeVersion;
-
-mod pkg_info;
-pub use crate::pkg_info::{PKG_DESCRIPTION, PKG_NAME, PKG_VERSION};
-
-mod unicode_version;
-pub use crate::unicode_version::UNICODE_VERSION;
diff --git a/vendor/unic-ucd-version/src/pkg_info.rs b/vendor/unic-ucd-version/src/pkg_info.rs
deleted file mode 100644
index a1ab2853f..000000000
--- a/vendor/unic-ucd-version/src/pkg_info.rs
+++ /dev/null
@@ -1,20 +0,0 @@
-// Copyright 2017 The UNIC Project Developers.
-//
-// See the COPYRIGHT file at the top-level directory of this distribution.
-//
-// Licensed under the Apache License, Version 2.0 <LICENSE-APACHE or
-// http://www.apache.org/licenses/LICENSE-2.0> or the MIT license
-// <LICENSE-MIT or http://opensource.org/licenses/MIT>, at your
-// option. This file may not be copied, modified, or distributed
-// except according to those terms.
-
-//! Package information
-
-/// UNIC component version.
-pub const PKG_VERSION: &str = env!("CARGO_PKG_VERSION");
-
-/// UNIC component name.
-pub const PKG_NAME: &str = env!("CARGO_PKG_NAME");
-
-/// UNIC component description.
-pub const PKG_DESCRIPTION: &str = env!("CARGO_PKG_DESCRIPTION");
diff --git a/vendor/unic-ucd-version/src/unicode_version.rs b/vendor/unic-ucd-version/src/unicode_version.rs
deleted file mode 100644
index 8e96e7f0a..000000000
--- a/vendor/unic-ucd-version/src/unicode_version.rs
+++ /dev/null
@@ -1,29 +0,0 @@
-// Copyright 2017 The UNIC Project Developers.
-//
-// See the COPYRIGHT file at the top-level directory of this distribution.
-//
-// Licensed under the Apache License, Version 2.0 <LICENSE-APACHE or
-// http://www.apache.org/licenses/LICENSE-2.0> or the MIT license
-// <LICENSE-MIT or http://opensource.org/licenses/MIT>, at your
-// option. This file may not be copied, modified, or distributed
-// except according to those terms.
-
-use unic_common::version::UnicodeVersion;
-
-/// The [Version of The Unicode Standard](https://www.unicode.org/versions/) of the Unicode
-/// Character Database in use.
-pub const UNICODE_VERSION: UnicodeVersion = include!("../tables/unicode_version.rsv");
-
-#[cfg(test)]
-mod tests {
- use super::UNICODE_VERSION;
-
- #[test]
- fn validate_version_values() {
- assert!(UNICODE_VERSION.major > 0);
-
- // Current release schedule of Unicode is to have one Major version update each year, with
- // no Minor updates. We hard-code this internal policy while it stands.
- assert!(UNICODE_VERSION.minor == 0);
- }
-}
diff --git a/vendor/unic-ucd-version/tables/unicode_version.rsv b/vendor/unic-ucd-version/tables/unicode_version.rsv
deleted file mode 100644
index 63d0ef157..000000000
--- a/vendor/unic-ucd-version/tables/unicode_version.rsv
+++ /dev/null
@@ -1,3 +0,0 @@
-// WARNING: Auto-generated by the `unic-gen` crate.
-// WARNING: DO NOT EDIT MANUALLY!
-UnicodeVersion { major: 10, minor: 0, micro: 0 }
diff --git a/vendor/unic-ucd-version/tests/basic_tests.rs b/vendor/unic-ucd-version/tests/basic_tests.rs
deleted file mode 100644
index e385bcf98..000000000
--- a/vendor/unic-ucd-version/tests/basic_tests.rs
+++ /dev/null
@@ -1,26 +0,0 @@
-// Copyright 2017 The UNIC Project Developers.
-//
-// See the COPYRIGHT file at the top-level directory of this distribution.
-//
-// Licensed under the Apache License, Version 2.0 <LICENSE-APACHE or
-// http://www.apache.org/licenses/LICENSE-2.0> or the MIT license
-// <LICENSE-MIT or http://opensource.org/licenses/MIT>, at your
-// option. This file may not be copied, modified, or distributed
-// except according to those terms.
-
-use unic_ucd_version::UnicodeVersion;
-
-#[test]
-fn test_display() {
- assert_eq!(
- format!(
- "Unicode {}",
- UnicodeVersion {
- major: 1,
- minor: 2,
- micro: 0,
- }
- ),
- "Unicode 1.2.0"
- );
-}