summaryrefslogtreecommitdiffstats
path: root/vendor/unicode-normalization/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/unicode-normalization/Cargo.toml')
-rw-r--r--vendor/unicode-normalization/Cargo.toml52
1 files changed, 52 insertions, 0 deletions
diff --git a/vendor/unicode-normalization/Cargo.toml b/vendor/unicode-normalization/Cargo.toml
new file mode 100644
index 000000000..417d04ce9
--- /dev/null
+++ b/vendor/unicode-normalization/Cargo.toml
@@ -0,0 +1,52 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "unicode-normalization"
+version = "0.1.21"
+authors = [
+ "kwantam <kwantam@gmail.com>",
+ "Manish Goregaokar <manishsmail@gmail.com>",
+]
+exclude = [
+ "target/*",
+ "Cargo.lock",
+ "scripts/tmp",
+ "*.txt",
+ "tests/*",
+]
+description = """
+This crate provides functions for normalization of
+Unicode strings, including Canonical and Compatible
+Decomposition and Recomposition, as described in
+Unicode Standard Annex #15.
+"""
+homepage = "https://github.com/unicode-rs/unicode-normalization"
+documentation = "https://docs.rs/unicode-normalization/"
+readme = "README.md"
+keywords = [
+ "text",
+ "unicode",
+ "normalization",
+ "decomposition",
+ "recomposition",
+]
+license = "MIT/Apache-2.0"
+repository = "https://github.com/unicode-rs/unicode-normalization"
+
+[dependencies.tinyvec]
+version = "1"
+features = ["alloc"]
+
+[features]
+default = ["std"]
+std = []