summaryrefslogtreecommitdiffstats
path: root/vendor/unicode-script/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--vendor/unicode-script/Cargo.toml36
1 files changed, 26 insertions, 10 deletions
diff --git a/vendor/unicode-script/Cargo.toml b/vendor/unicode-script/Cargo.toml
index 6dfc01148..c2647d3ab 100644
--- a/vendor/unicode-script/Cargo.toml
+++ b/vendor/unicode-script/Cargo.toml
@@ -3,26 +3,38 @@
# When uploading crates to the registry Cargo will automatically
# "normalize" Cargo.toml files for maximal compatibility
# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies
+# to registry (e.g., crates.io) dependencies.
#
-# If you believe there's an error in this file please file an
-# issue against the rust-lang/cargo repository. If you're
-# editing this file be aware that the upstream Cargo.toml
-# will likely look very different (and much more reasonable)
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
[package]
edition = "2018"
name = "unicode-script"
-version = "0.5.3"
+version = "0.5.5"
authors = ["Manish Goregaokar <manishsmail@gmail.com>"]
-exclude = ["target/*", "Cargo.lock", "scripts/tmp", "*.txt"]
-description = "This crate exposes the Unicode `Script` and `Script_Extension` properties from [UAX #24](http://www.unicode.org/reports/tr24/)\n"
+exclude = [
+ "target/*",
+ "Cargo.lock",
+ "scripts/tmp",
+ "*.txt",
+]
+description = """
+This crate exposes the Unicode `Script` and `Script_Extension` properties from [UAX #24](http://www.unicode.org/reports/tr24/)
+"""
homepage = "https://github.com/unicode-rs/unicode-script"
documentation = "https://docs.rs/unicode-script"
readme = "README.md"
-keywords = ["text", "unicode", "script", "language"]
+keywords = [
+ "text",
+ "unicode",
+ "script",
+ "language",
+]
license = "MIT/Apache-2.0"
repository = "https://github.com/unicode-rs/unicode-script"
+
[dependencies.compiler_builtins]
version = "0.1"
optional = true
@@ -39,4 +51,8 @@ package = "rustc-std-workspace-std"
[features]
bench = []
-rustc-dep-of-std = ["std", "core", "compiler_builtins"]
+rustc-dep-of-std = [
+ "std",
+ "core",
+ "compiler_builtins",
+]