summaryrefslogtreecommitdiffstats
path: root/vendor/unicode-script/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/unicode-script/Cargo.toml')
-rw-r--r--vendor/unicode-script/Cargo.toml42
1 files changed, 42 insertions, 0 deletions
diff --git a/vendor/unicode-script/Cargo.toml b/vendor/unicode-script/Cargo.toml
new file mode 100644
index 000000000..6dfc01148
--- /dev/null
+++ b/vendor/unicode-script/Cargo.toml
@@ -0,0 +1,42 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "unicode-script"
+version = "0.5.3"
+authors = ["Manish Goregaokar <manishsmail@gmail.com>"]
+exclude = ["target/*", "Cargo.lock", "scripts/tmp", "*.txt"]
+description = "This crate exposes the Unicode `Script` and `Script_Extension` properties from [UAX #24](http://www.unicode.org/reports/tr24/)\n"
+homepage = "https://github.com/unicode-rs/unicode-script"
+documentation = "https://docs.rs/unicode-script"
+readme = "README.md"
+keywords = ["text", "unicode", "script", "language"]
+license = "MIT/Apache-2.0"
+repository = "https://github.com/unicode-rs/unicode-script"
+[dependencies.compiler_builtins]
+version = "0.1"
+optional = true
+
+[dependencies.core]
+version = "1.0"
+optional = true
+package = "rustc-std-workspace-core"
+
+[dependencies.std]
+version = "1.0"
+optional = true
+package = "rustc-std-workspace-std"
+
+[features]
+bench = []
+rustc-dep-of-std = ["std", "core", "compiler_builtins"]