summaryrefslogtreecommitdiffstats
path: root/vendor/unicode-width/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/unicode-width/Cargo.toml')
-rw-r--r--vendor/unicode-width/Cargo.toml42
1 files changed, 42 insertions, 0 deletions
diff --git a/vendor/unicode-width/Cargo.toml b/vendor/unicode-width/Cargo.toml
new file mode 100644
index 000000000..9cb47d54c
--- /dev/null
+++ b/vendor/unicode-width/Cargo.toml
@@ -0,0 +1,42 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+name = "unicode-width"
+version = "0.1.9"
+authors = ["kwantam <kwantam@gmail.com>", "Manish Goregaokar <manishsmail@gmail.com>"]
+exclude = ["target/*", "Cargo.lock"]
+description = "Determine displayed width of `char` and `str` types\naccording to Unicode Standard Annex #11 rules.\n"
+homepage = "https://github.com/unicode-rs/unicode-width"
+documentation = "https://unicode-rs.github.io/unicode-width"
+readme = "README.md"
+keywords = ["text", "width", "unicode"]
+license = "MIT/Apache-2.0"
+repository = "https://github.com/unicode-rs/unicode-width"
+[dependencies.compiler_builtins]
+version = "0.1"
+optional = true
+
+[dependencies.core]
+version = "1.0"
+optional = true
+package = "rustc-std-workspace-core"
+
+[dependencies.std]
+version = "1.0"
+optional = true
+package = "rustc-std-workspace-std"
+
+[features]
+bench = []
+default = []
+no_std = []
+rustc-dep-of-std = ["std", "core", "compiler_builtins"]