summaryrefslogtreecommitdiffstats
path: root/vendor/uuid/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/uuid/Cargo.toml')
-rw-r--r--vendor/uuid/Cargo.toml91
1 files changed, 91 insertions, 0 deletions
diff --git a/vendor/uuid/Cargo.toml b/vendor/uuid/Cargo.toml
new file mode 100644
index 000000000..1803f733d
--- /dev/null
+++ b/vendor/uuid/Cargo.toml
@@ -0,0 +1,91 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "uuid"
+version = "0.8.2"
+authors = ["Ashley Mannix<ashleymannix@live.com.au>", "Christopher Armstrong", "Dylan DPC<dylan.dpc@gmail.com>", "Hunar Roop Kahlon<hunar.roop@gmail.com>"]
+exclude = [".github/**", ".travis.yml", "appveyor.yml", "bors.toml"]
+description = "A library to generate and parse UUIDs."
+homepage = "https://github.com/uuid-rs/uuid"
+documentation = "https://docs.rs/uuid"
+readme = "README.md"
+keywords = ["guid", "unique", "uuid"]
+categories = ["data-structures", "no-std", "parser-implementations", "wasm"]
+license = "Apache-2.0 OR MIT"
+repository = "https://github.com/uuid-rs/uuid"
+[package.metadata.docs.rs]
+default-target = "x86_64-pc-windows-msvc"
+features = ["guid", "serde", "slog", "v1", "v3", "v4", "v5"]
+
+[package.metadata.playground]
+features = ["serde", "v1", "v3", "v4", "v5"]
+[dependencies.getrandom]
+version = "0.2.0"
+optional = true
+
+[dependencies.md5]
+version = "0.7"
+optional = true
+
+[dependencies.serde]
+version = "1.0.56"
+optional = true
+default-features = false
+
+[dependencies.sha1]
+version = "0.6"
+optional = true
+
+[dependencies.slog]
+version = "2"
+optional = true
+[dev-dependencies.bincode]
+version = "1.0"
+
+[dev-dependencies.serde_derive]
+version = "1.0.79"
+
+[dev-dependencies.serde_json]
+version = "1.0"
+
+[dev-dependencies.serde_test]
+version = "1.0.56"
+
+[features]
+default = ["std"]
+guid = ["winapi"]
+std = []
+stdweb = ["getrandom", "getrandom/js"]
+v1 = []
+v3 = ["md5"]
+v4 = ["getrandom"]
+v5 = ["sha1"]
+wasm-bindgen = ["getrandom", "getrandom/js"]
+[target."cfg(windows)".dependencies.winapi]
+version = "0.3"
+optional = true
+[badges.appveyor]
+repository = "uuid-rs/uuid"
+
+[badges.is-it-maintained-issue-resolution]
+repository = "uuid-rs/uuid"
+
+[badges.is-it-maintained-open-issues]
+repository = "uuid-rs/uuid"
+
+[badges.maintenance]
+status = "actively-developed"
+
+[badges.travis-ci]
+repository = "uuid-rs/uuid"