summaryrefslogtreecommitdiffstats
path: root/vendor/vcpkg/tests/run.sh
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/vcpkg/tests/run.sh')
-rw-r--r--vendor/vcpkg/tests/run.sh20
1 files changed, 0 insertions, 20 deletions
diff --git a/vendor/vcpkg/tests/run.sh b/vendor/vcpkg/tests/run.sh
deleted file mode 100644
index b9dcdb369..000000000
--- a/vendor/vcpkg/tests/run.sh
+++ /dev/null
@@ -1,20 +0,0 @@
-#!/bin/bash
-set -ex
-
-SCRIPTDIR="$( cd "$( dirname "${BASH_SOURCE[0]}" )" && pwd )"
-cd $SCRIPTDIR
-
-export VCPKG_ROOT=$SCRIPTDIR/../vcp
-
-source ../setup_vcp.sh
-
-for port in harfbuzz ; do
- # check that the port fails before it is installed
- $VCPKG_ROOT/vcpkg remove $port || true
- cargo clean --manifest-path $port/Cargo.toml
- cargo run --manifest-path $port/Cargo.toml && exit 2
- echo THIS FAILURE IS EXPECTED
- echo This is to ensure that we are not spuriously succeeding because the libraries already exist somewhere on the build machine.
- $VCPKG_ROOT/vcpkg install $port
- cargo run --manifest-path $port/Cargo.toml
-done