summaryrefslogtreecommitdiffstats
path: root/vendor/wasi-0.10.2+wasi-snapshot-preview1/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--vendor/wasi-0.10.2+wasi-snapshot-preview1/Cargo.toml43
1 files changed, 43 insertions, 0 deletions
diff --git a/vendor/wasi-0.10.2+wasi-snapshot-preview1/Cargo.toml b/vendor/wasi-0.10.2+wasi-snapshot-preview1/Cargo.toml
new file mode 100644
index 000000000..23e3b2f6e
--- /dev/null
+++ b/vendor/wasi-0.10.2+wasi-snapshot-preview1/Cargo.toml
@@ -0,0 +1,43 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "wasi"
+version = "0.10.2+wasi-snapshot-preview1"
+authors = ["The Cranelift Project Developers"]
+description = "Experimental WASI API bindings for Rust"
+documentation = "https://docs.rs/wasi"
+readme = "README.md"
+keywords = ["webassembly", "wasm"]
+categories = ["no-std", "wasm"]
+license = "Apache-2.0 WITH LLVM-exception OR Apache-2.0 OR MIT"
+repository = "https://github.com/bytecodealliance/wasi"
+[dependencies.compiler_builtins]
+version = "0.1"
+optional = true
+
+[dependencies.core]
+version = "1.0"
+optional = true
+package = "rustc-std-workspace-core"
+
+[dependencies.rustc-std-workspace-alloc]
+version = "1.0"
+optional = true
+
+[features]
+default = ["std"]
+rustc-dep-of-std = ["compiler_builtins", "core", "rustc-std-workspace-alloc"]
+std = []
+[badges.maintenance]
+status = "experimental"