summaryrefslogtreecommitdiffstats
path: root/vendor/wasm-bindgen-macro/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/wasm-bindgen-macro/Cargo.toml')
-rw-r--r--vendor/wasm-bindgen-macro/Cargo.toml47
1 files changed, 47 insertions, 0 deletions
diff --git a/vendor/wasm-bindgen-macro/Cargo.toml b/vendor/wasm-bindgen-macro/Cargo.toml
new file mode 100644
index 000000000..99d0e52a5
--- /dev/null
+++ b/vendor/wasm-bindgen-macro/Cargo.toml
@@ -0,0 +1,47 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "wasm-bindgen-macro"
+version = "0.2.83"
+authors = ["The wasm-bindgen Developers"]
+description = """
+Definition of the `#[wasm_bindgen]` attribute, an internal dependency
+"""
+homepage = "https://rustwasm.github.io/wasm-bindgen/"
+documentation = "https://docs.rs/wasm-bindgen"
+readme = "README.md"
+license = "MIT/Apache-2.0"
+repository = "https://github.com/rustwasm/wasm-bindgen/tree/master/crates/macro"
+
+[lib]
+proc-macro = true
+
+[dependencies.quote]
+version = "1.0"
+
+[dependencies.wasm-bindgen-macro-support]
+version = "=0.2.83"
+
+[dev-dependencies.trybuild]
+version = "1.0"
+
+[dev-dependencies.wasm-bindgen]
+version = "0.2.83"
+
+[dev-dependencies.wasm-bindgen-futures]
+version = "0.4.33"
+
+[features]
+spans = ["wasm-bindgen-macro-support/spans"]
+strict-macro = ["wasm-bindgen-macro-support/strict-macro"]
+xxx_debug_only_print_generated_code = []