summaryrefslogtreecommitdiffstats
path: root/vendor/windows-sys/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/windows-sys/Cargo.toml')
-rw-r--r--vendor/windows-sys/Cargo.toml402
1 files changed, 18 insertions, 384 deletions
diff --git a/vendor/windows-sys/Cargo.toml b/vendor/windows-sys/Cargo.toml
index 4ab32fa98..464aa786f 100644
--- a/vendor/windows-sys/Cargo.toml
+++ b/vendor/windows-sys/Cargo.toml
@@ -11,9 +11,9 @@
[package]
edition = "2018"
-rust-version = "1.46"
+rust-version = "1.49"
name = "windows-sys"
-version = "0.36.1"
+version = "0.42.0"
authors = ["Microsoft"]
description = "Rust for Windows"
readme = "readme.md"
@@ -26,374 +26,6 @@ targets = []
all-features = true
[features]
-AI = []
-AI_MachineLearning = ["AI"]
-AI_MachineLearning_Preview = ["AI_MachineLearning"]
-ApplicationModel = []
-ApplicationModel_Activation = ["ApplicationModel"]
-ApplicationModel_AppExtensions = ["ApplicationModel"]
-ApplicationModel_AppService = ["ApplicationModel"]
-ApplicationModel_Appointments = ["ApplicationModel"]
-ApplicationModel_Appointments_AppointmentsProvider = ["ApplicationModel_Appointments"]
-ApplicationModel_Appointments_DataProvider = ["ApplicationModel_Appointments"]
-ApplicationModel_Background = ["ApplicationModel"]
-ApplicationModel_Calls = ["ApplicationModel"]
-ApplicationModel_Calls_Background = ["ApplicationModel_Calls"]
-ApplicationModel_Calls_Provider = ["ApplicationModel_Calls"]
-ApplicationModel_Chat = ["ApplicationModel"]
-ApplicationModel_CommunicationBlocking = ["ApplicationModel"]
-ApplicationModel_Contacts = ["ApplicationModel"]
-ApplicationModel_Contacts_DataProvider = ["ApplicationModel_Contacts"]
-ApplicationModel_Contacts_Provider = ["ApplicationModel_Contacts"]
-ApplicationModel_ConversationalAgent = ["ApplicationModel"]
-ApplicationModel_Core = ["ApplicationModel"]
-ApplicationModel_DataTransfer = ["ApplicationModel"]
-ApplicationModel_DataTransfer_DragDrop = ["ApplicationModel_DataTransfer"]
-ApplicationModel_DataTransfer_DragDrop_Core = ["ApplicationModel_DataTransfer_DragDrop"]
-ApplicationModel_DataTransfer_ShareTarget = ["ApplicationModel_DataTransfer"]
-ApplicationModel_Email = ["ApplicationModel"]
-ApplicationModel_Email_DataProvider = ["ApplicationModel_Email"]
-ApplicationModel_ExtendedExecution = ["ApplicationModel"]
-ApplicationModel_ExtendedExecution_Foreground = ["ApplicationModel_ExtendedExecution"]
-ApplicationModel_Holographic = ["ApplicationModel"]
-ApplicationModel_LockScreen = ["ApplicationModel"]
-ApplicationModel_Payments = ["ApplicationModel"]
-ApplicationModel_Payments_Provider = ["ApplicationModel_Payments"]
-ApplicationModel_Preview = ["ApplicationModel"]
-ApplicationModel_Preview_Holographic = ["ApplicationModel_Preview"]
-ApplicationModel_Preview_InkWorkspace = ["ApplicationModel_Preview"]
-ApplicationModel_Preview_Notes = ["ApplicationModel_Preview"]
-ApplicationModel_Resources = ["ApplicationModel"]
-ApplicationModel_Resources_Core = ["ApplicationModel_Resources"]
-ApplicationModel_Resources_Management = ["ApplicationModel_Resources"]
-ApplicationModel_Search = ["ApplicationModel"]
-ApplicationModel_Search_Core = ["ApplicationModel_Search"]
-ApplicationModel_SocialInfo = ["ApplicationModel"]
-ApplicationModel_SocialInfo_Provider = ["ApplicationModel_SocialInfo"]
-ApplicationModel_Store = ["ApplicationModel"]
-ApplicationModel_Store_LicenseManagement = ["ApplicationModel_Store"]
-ApplicationModel_Store_Preview = ["ApplicationModel_Store"]
-ApplicationModel_Store_Preview_InstallControl = ["ApplicationModel_Store_Preview"]
-ApplicationModel_UserActivities = ["ApplicationModel"]
-ApplicationModel_UserActivities_Core = ["ApplicationModel_UserActivities"]
-ApplicationModel_UserDataAccounts = ["ApplicationModel"]
-ApplicationModel_UserDataAccounts_Provider = ["ApplicationModel_UserDataAccounts"]
-ApplicationModel_UserDataAccounts_SystemAccess = ["ApplicationModel_UserDataAccounts"]
-ApplicationModel_UserDataTasks = ["ApplicationModel"]
-ApplicationModel_UserDataTasks_DataProvider = ["ApplicationModel_UserDataTasks"]
-ApplicationModel_VoiceCommands = ["ApplicationModel"]
-ApplicationModel_Wallet = ["ApplicationModel"]
-ApplicationModel_Wallet_System = ["ApplicationModel_Wallet"]
-Data = []
-Data_Html = ["Data"]
-Data_Json = ["Data"]
-Data_Pdf = ["Data"]
-Data_Text = ["Data"]
-Data_Xml = ["Data"]
-Data_Xml_Dom = ["Data_Xml"]
-Data_Xml_Xsl = ["Data_Xml"]
-Devices = []
-Devices_Adc = ["Devices"]
-Devices_Adc_Provider = ["Devices_Adc"]
-Devices_AllJoyn = ["Devices"]
-Devices_Background = ["Devices"]
-Devices_Bluetooth = ["Devices"]
-Devices_Bluetooth_Advertisement = ["Devices_Bluetooth"]
-Devices_Bluetooth_Background = ["Devices_Bluetooth"]
-Devices_Bluetooth_GenericAttributeProfile = ["Devices_Bluetooth"]
-Devices_Bluetooth_Rfcomm = ["Devices_Bluetooth"]
-Devices_Custom = ["Devices"]
-Devices_Display = ["Devices"]
-Devices_Display_Core = ["Devices_Display"]
-Devices_Enumeration = ["Devices"]
-Devices_Enumeration_Pnp = ["Devices_Enumeration"]
-Devices_Geolocation = ["Devices"]
-Devices_Geolocation_Geofencing = ["Devices_Geolocation"]
-Devices_Gpio = ["Devices"]
-Devices_Gpio_Provider = ["Devices_Gpio"]
-Devices_Haptics = ["Devices"]
-Devices_HumanInterfaceDevice = ["Devices"]
-Devices_I2c = ["Devices"]
-Devices_I2c_Provider = ["Devices_I2c"]
-Devices_Input = ["Devices"]
-Devices_Input_Preview = ["Devices_Input"]
-Devices_Lights = ["Devices"]
-Devices_Lights_Effects = ["Devices_Lights"]
-Devices_Midi = ["Devices"]
-Devices_Perception = ["Devices"]
-Devices_Perception_Provider = ["Devices_Perception"]
-Devices_PointOfService = ["Devices"]
-Devices_PointOfService_Provider = ["Devices_PointOfService"]
-Devices_Portable = ["Devices"]
-Devices_Power = ["Devices"]
-Devices_Printers = ["Devices"]
-Devices_Printers_Extensions = ["Devices_Printers"]
-Devices_Pwm = ["Devices"]
-Devices_Pwm_Provider = ["Devices_Pwm"]
-Devices_Radios = ["Devices"]
-Devices_Scanners = ["Devices"]
-Devices_Sensors = ["Devices"]
-Devices_Sensors_Custom = ["Devices_Sensors"]
-Devices_SerialCommunication = ["Devices"]
-Devices_SmartCards = ["Devices"]
-Devices_Sms = ["Devices"]
-Devices_Spi = ["Devices"]
-Devices_Spi_Provider = ["Devices_Spi"]
-Devices_Usb = ["Devices"]
-Devices_WiFi = ["Devices"]
-Devices_WiFiDirect = ["Devices"]
-Devices_WiFiDirect_Services = ["Devices_WiFiDirect"]
-Embedded = []
-Embedded_DeviceLockdown = ["Embedded"]
-Foundation = []
-Foundation_Collections = ["Foundation"]
-Foundation_Diagnostics = ["Foundation"]
-Foundation_Metadata = ["Foundation"]
-Foundation_Numerics = ["Foundation"]
-Gaming = []
-Gaming_Input = ["Gaming"]
-Gaming_Input_Custom = ["Gaming_Input"]
-Gaming_Input_ForceFeedback = ["Gaming_Input"]
-Gaming_Input_Preview = ["Gaming_Input"]
-Gaming_Preview = ["Gaming"]
-Gaming_Preview_GamesEnumeration = ["Gaming_Preview"]
-Gaming_UI = ["Gaming"]
-Gaming_XboxLive = ["Gaming"]
-Gaming_XboxLive_Storage = ["Gaming_XboxLive"]
-Globalization = []
-Globalization_Collation = ["Globalization"]
-Globalization_DateTimeFormatting = ["Globalization"]
-Globalization_Fonts = ["Globalization"]
-Globalization_NumberFormatting = ["Globalization"]
-Globalization_PhoneNumberFormatting = ["Globalization"]
-Graphics = []
-Graphics_Capture = ["Graphics"]
-Graphics_DirectX = ["Graphics"]
-Graphics_DirectX_Direct3D11 = ["Graphics_DirectX"]
-Graphics_Display = ["Graphics"]
-Graphics_Display_Core = ["Graphics_Display"]
-Graphics_Effects = ["Graphics"]
-Graphics_Holographic = ["Graphics"]
-Graphics_Imaging = ["Graphics"]
-Graphics_Printing = ["Graphics"]
-Graphics_Printing3D = ["Graphics"]
-Graphics_Printing_OptionDetails = ["Graphics_Printing"]
-Graphics_Printing_PrintSupport = ["Graphics_Printing"]
-Graphics_Printing_PrintTicket = ["Graphics_Printing"]
-Graphics_Printing_Workflow = ["Graphics_Printing"]
-Management = []
-Management_Core = ["Management"]
-Management_Deployment = ["Management"]
-Management_Deployment_Preview = ["Management_Deployment"]
-Management_Policies = ["Management"]
-Management_Update = ["Management"]
-Management_Workplace = ["Management"]
-Media = []
-Media_AppBroadcasting = ["Media"]
-Media_AppRecording = ["Media"]
-Media_Audio = ["Media"]
-Media_Capture = ["Media"]
-Media_Capture_Core = ["Media_Capture"]
-Media_Capture_Frames = ["Media_Capture"]
-Media_Casting = ["Media"]
-Media_ClosedCaptioning = ["Media"]
-Media_ContentRestrictions = ["Media"]
-Media_Control = ["Media"]
-Media_Core = ["Media"]
-Media_Core_Preview = ["Media_Core"]
-Media_Devices = ["Media"]
-Media_Devices_Core = ["Media_Devices"]
-Media_DialProtocol = ["Media"]
-Media_Editing = ["Media"]
-Media_Effects = ["Media"]
-Media_FaceAnalysis = ["Media"]
-Media_Import = ["Media"]
-Media_MediaProperties = ["Media"]
-Media_Miracast = ["Media"]
-Media_Ocr = ["Media"]
-Media_PlayTo = ["Media"]
-Media_Playback = ["Media"]
-Media_Playlists = ["Media"]
-Media_Protection = ["Media"]
-Media_Protection_PlayReady = ["Media_Protection"]
-Media_Render = ["Media"]
-Media_SpeechRecognition = ["Media"]
-Media_SpeechSynthesis = ["Media"]
-Media_Streaming = ["Media"]
-Media_Streaming_Adaptive = ["Media_Streaming"]
-Media_Transcoding = ["Media"]
-Networking = []
-Networking_BackgroundTransfer = ["Networking"]
-Networking_Connectivity = ["Networking"]
-Networking_NetworkOperators = ["Networking"]
-Networking_Proximity = ["Networking"]
-Networking_PushNotifications = ["Networking"]
-Networking_ServiceDiscovery = ["Networking"]
-Networking_ServiceDiscovery_Dnssd = ["Networking_ServiceDiscovery"]
-Networking_Sockets = ["Networking"]
-Networking_Vpn = ["Networking"]
-Networking_XboxLive = ["Networking"]
-Perception = []
-Perception_Automation = ["Perception"]
-Perception_Automation_Core = ["Perception_Automation"]
-Perception_People = ["Perception"]
-Perception_Spatial = ["Perception"]
-Perception_Spatial_Preview = ["Perception_Spatial"]
-Perception_Spatial_Surfaces = ["Perception_Spatial"]
-Phone = []
-Phone_ApplicationModel = ["Phone"]
-Phone_Devices = ["Phone"]
-Phone_Devices_Notification = ["Phone_Devices"]
-Phone_Devices_Power = ["Phone_Devices"]
-Phone_Management = ["Phone"]
-Phone_Management_Deployment = ["Phone_Management"]
-Phone_Media = ["Phone"]
-Phone_Media_Devices = ["Phone_Media"]
-Phone_Notification = ["Phone"]
-Phone_Notification_Management = ["Phone_Notification"]
-Phone_PersonalInformation = ["Phone"]
-Phone_PersonalInformation_Provisioning = ["Phone_PersonalInformation"]
-Phone_Speech = ["Phone"]
-Phone_Speech_Recognition = ["Phone_Speech"]
-Phone_StartScreen = ["Phone"]
-Phone_System = ["Phone"]
-Phone_System_Power = ["Phone_System"]
-Phone_System_Profile = ["Phone_System"]
-Phone_System_UserProfile = ["Phone_System"]
-Phone_System_UserProfile_GameServices = ["Phone_System_UserProfile"]
-Phone_System_UserProfile_GameServices_Core = ["Phone_System_UserProfile_GameServices"]
-Phone_UI = ["Phone"]
-Phone_UI_Input = ["Phone_UI"]
-Security = []
-Security_Authentication = ["Security"]
-Security_Authentication_Identity = ["Security_Authentication"]
-Security_Authentication_Identity_Core = ["Security_Authentication_Identity"]
-Security_Authentication_Identity_Provider = ["Security_Authentication_Identity"]
-Security_Authentication_OnlineId = ["Security_Authentication"]
-Security_Authentication_Web = ["Security_Authentication"]
-Security_Authentication_Web_Core = ["Security_Authentication_Web"]
-Security_Authentication_Web_Provider = ["Security_Authentication_Web"]
-Security_Authorization = ["Security"]
-Security_Authorization_AppCapabilityAccess = ["Security_Authorization"]
-Security_Credentials = ["Security"]
-Security_Credentials_UI = ["Security_Credentials"]
-Security_Cryptography = ["Security"]
-Security_Cryptography_Certificates = ["Security_Cryptography"]
-Security_Cryptography_Core = ["Security_Cryptography"]
-Security_Cryptography_DataProtection = ["Security_Cryptography"]
-Security_DataProtection = ["Security"]
-Security_EnterpriseData = ["Security"]
-Security_ExchangeActiveSyncProvisioning = ["Security"]
-Security_Isolation = ["Security"]
-Services = []
-Services_Cortana = ["Services"]
-Services_Maps = ["Services"]
-Services_Maps_Guidance = ["Services_Maps"]
-Services_Maps_LocalSearch = ["Services_Maps"]
-Services_Maps_OfflineMaps = ["Services_Maps"]
-Services_Store = ["Services"]
-Services_TargetedContent = ["Services"]
-Storage = []
-Storage_AccessCache = ["Storage"]
-Storage_BulkAccess = ["Storage"]
-Storage_Compression = ["Storage"]
-Storage_FileProperties = ["Storage"]
-Storage_Pickers = ["Storage"]
-Storage_Pickers_Provider = ["Storage_Pickers"]
-Storage_Provider = ["Storage"]
-Storage_Search = ["Storage"]
-Storage_Streams = ["Storage"]
-System = []
-System_Diagnostics = ["System"]
-System_Diagnostics_DevicePortal = ["System_Diagnostics"]
-System_Diagnostics_Telemetry = ["System_Diagnostics"]
-System_Diagnostics_TraceReporting = ["System_Diagnostics"]
-System_Display = ["System"]
-System_Implementation = ["System"]
-System_Implementation_FileExplorer = ["System_Implementation"]
-System_Inventory = ["System"]
-System_Power = ["System"]
-System_Power_Diagnostics = ["System_Power"]
-System_Preview = ["System"]
-System_Profile = ["System"]
-System_Profile_SystemManufacturers = ["System_Profile"]
-System_RemoteDesktop = ["System"]
-System_RemoteDesktop_Input = ["System_RemoteDesktop"]
-System_RemoteSystems = ["System"]
-System_Threading = ["System"]
-System_Threading_Core = ["System_Threading"]
-System_Update = ["System"]
-System_UserProfile = ["System"]
-UI = []
-UI_Accessibility = ["UI"]
-UI_ApplicationSettings = ["UI"]
-UI_Composition = ["UI"]
-UI_Composition_Core = ["UI_Composition"]
-UI_Composition_Desktop = ["UI_Composition"]
-UI_Composition_Diagnostics = ["UI_Composition"]
-UI_Composition_Effects = ["UI_Composition"]
-UI_Composition_Interactions = ["UI_Composition"]
-UI_Composition_Scenes = ["UI_Composition"]
-UI_Core = ["UI"]
-UI_Core_AnimationMetrics = ["UI_Core"]
-UI_Core_Preview = ["UI_Core"]
-UI_Input = ["UI"]
-UI_Input_Core = ["UI_Input"]
-UI_Input_Inking = ["UI_Input"]
-UI_Input_Inking_Analysis = ["UI_Input_Inking"]
-UI_Input_Inking_Core = ["UI_Input_Inking"]
-UI_Input_Inking_Preview = ["UI_Input_Inking"]
-UI_Input_Preview = ["UI_Input"]
-UI_Input_Preview_Injection = ["UI_Input_Preview"]
-UI_Input_Spatial = ["UI_Input"]
-UI_Notifications = ["UI"]
-UI_Notifications_Management = ["UI_Notifications"]
-UI_Popups = ["UI"]
-UI_Shell = ["UI"]
-UI_StartScreen = ["UI"]
-UI_Text = ["UI"]
-UI_Text_Core = ["UI_Text"]
-UI_UIAutomation = ["UI"]
-UI_UIAutomation_Core = ["UI_UIAutomation"]
-UI_ViewManagement = ["UI"]
-UI_ViewManagement_Core = ["UI_ViewManagement"]
-UI_WebUI = ["UI"]
-UI_WebUI_Core = ["UI_WebUI"]
-UI_WindowManagement = ["UI"]
-UI_WindowManagement_Preview = ["UI_WindowManagement"]
-UI_Xaml = ["UI"]
-UI_Xaml_Automation = ["UI_Xaml"]
-UI_Xaml_Automation_Peers = ["UI_Xaml_Automation"]
-UI_Xaml_Automation_Provider = ["UI_Xaml_Automation"]
-UI_Xaml_Automation_Text = ["UI_Xaml_Automation"]
-UI_Xaml_Controls = ["UI_Xaml"]
-UI_Xaml_Controls_Maps = ["UI_Xaml_Controls"]
-UI_Xaml_Controls_Primitives = ["UI_Xaml_Controls"]
-UI_Xaml_Core = ["UI_Xaml"]
-UI_Xaml_Core_Direct = ["UI_Xaml_Core"]
-UI_Xaml_Data = ["UI_Xaml"]
-UI_Xaml_Documents = ["UI_Xaml"]
-UI_Xaml_Hosting = ["UI_Xaml"]
-UI_Xaml_Input = ["UI_Xaml"]
-UI_Xaml_Interop = ["UI_Xaml"]
-UI_Xaml_Markup = ["UI_Xaml"]
-UI_Xaml_Media = ["UI_Xaml"]
-UI_Xaml_Media_Animation = ["UI_Xaml_Media"]
-UI_Xaml_Media_Imaging = ["UI_Xaml_Media"]
-UI_Xaml_Media_Media3D = ["UI_Xaml_Media"]
-UI_Xaml_Navigation = ["UI_Xaml"]
-UI_Xaml_Printing = ["UI_Xaml"]
-UI_Xaml_Resources = ["UI_Xaml"]
-UI_Xaml_Shapes = ["UI_Xaml"]
-Web = []
-Web_AtomPub = ["Web"]
-Web_Http = ["Web"]
-Web_Http_Diagnostics = ["Web_Http"]
-Web_Http_Filters = ["Web_Http"]
-Web_Http_Headers = ["Web_Http"]
-Web_Syndication = ["Web"]
-Web_UI = ["Web"]
-Web_UI_Interop = ["Web_UI"]
Win32 = []
Win32_AI = ["Win32"]
Win32_AI_MachineLearning = ["Win32_AI"]
@@ -596,7 +228,6 @@ Win32_System_DeveloperLicensing = ["Win32_System"]
Win32_System_Diagnostics = ["Win32_System"]
Win32_System_Diagnostics_Ceip = ["Win32_System_Diagnostics"]
Win32_System_Diagnostics_Debug = ["Win32_System_Diagnostics"]
-Win32_System_Diagnostics_Debug_WebApp = ["Win32_System_Diagnostics_Debug"]
Win32_System_Diagnostics_Etw = ["Win32_System_Diagnostics"]
Win32_System_Diagnostics_ProcessSnapshotting = ["Win32_System_Diagnostics"]
Win32_System_Diagnostics_ToolHelp = ["Win32_System_Diagnostics"]
@@ -682,7 +313,6 @@ Win32_System_WinRT_Pdf = ["Win32_System_WinRT"]
Win32_System_WinRT_Printing = ["Win32_System_WinRT"]
Win32_System_WinRT_Shell = ["Win32_System_WinRT"]
Win32_System_WinRT_Storage = ["Win32_System_WinRT"]
-Win32_System_WinRT_Xaml = ["Win32_System_WinRT"]
Win32_System_WindowsProgramming = ["Win32_System"]
Win32_System_WindowsSync = ["Win32_System"]
Win32_System_Wmi = ["Win32_System"]
@@ -716,37 +346,41 @@ Win32_UI_WindowsAndMessaging = ["Win32_UI"]
Win32_UI_Wpf = ["Win32_UI"]
Win32_UI_Xaml = ["Win32_UI"]
Win32_UI_Xaml_Diagnostics = ["Win32_UI_Xaml"]
-Win32_Web = ["Win32"]
-Win32_Web_MsHtml = ["Win32_Web"]
default = []
deprecated = []
+[target.aarch64-pc-windows-gnullvm.dependencies.windows_aarch64_gnullvm]
+version = "0.42.0"
+
[target.aarch64-pc-windows-msvc.dependencies.windows_aarch64_msvc]
-version = "0.36.1"
+version = "0.42.0"
[target.aarch64-uwp-windows-msvc.dependencies.windows_aarch64_msvc]
-version = "0.36.1"
+version = "0.42.0"
[target.i686-pc-windows-gnu.dependencies.windows_i686_gnu]
-version = "0.36.1"
+version = "0.42.0"
[target.i686-pc-windows-msvc.dependencies.windows_i686_msvc]
-version = "0.36.1"
+version = "0.42.0"
[target.i686-uwp-windows-gnu.dependencies.windows_i686_gnu]
-version = "0.36.1"
+version = "0.42.0"
[target.i686-uwp-windows-msvc.dependencies.windows_i686_msvc]
-version = "0.36.1"
+version = "0.42.0"
[target.x86_64-pc-windows-gnu.dependencies.windows_x86_64_gnu]
-version = "0.36.1"
+version = "0.42.0"
+
+[target.x86_64-pc-windows-gnullvm.dependencies.windows_x86_64_gnullvm]
+version = "0.42.0"
[target.x86_64-pc-windows-msvc.dependencies.windows_x86_64_msvc]
-version = "0.36.1"
+version = "0.42.0"
[target.x86_64-uwp-windows-gnu.dependencies.windows_x86_64_gnu]
-version = "0.36.1"
+version = "0.42.0"
[target.x86_64-uwp-windows-msvc.dependencies.windows_x86_64_msvc]
-version = "0.36.1"
+version = "0.42.0"