summaryrefslogtreecommitdiffstats
path: root/vendor/windows_x86_64_gnu
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--vendor/windows_x86_64_gnu-0.28.0/.cargo-checksum.json1
-rw-r--r--vendor/windows_x86_64_gnu-0.28.0/Cargo.toml18
-rw-r--r--vendor/windows_x86_64_gnu-0.28.0/build.rs9
-rw-r--r--vendor/windows_x86_64_gnu-0.28.0/lib/libwindows.abin0 -> 13666316 bytes
-rw-r--r--vendor/windows_x86_64_gnu-0.28.0/src/lib.rs1
-rw-r--r--vendor/windows_x86_64_gnu/.cargo-checksum.json1
-rw-r--r--vendor/windows_x86_64_gnu/Cargo.toml23
-rw-r--r--vendor/windows_x86_64_gnu/build.rs10
-rw-r--r--vendor/windows_x86_64_gnu/lib/libwindows.abin0 -> 13879932 bytes
-rw-r--r--vendor/windows_x86_64_gnu/src/lib.rs1
10 files changed, 64 insertions, 0 deletions
diff --git a/vendor/windows_x86_64_gnu-0.28.0/.cargo-checksum.json b/vendor/windows_x86_64_gnu-0.28.0/.cargo-checksum.json
new file mode 100644
index 000000000..ba868df80
--- /dev/null
+++ b/vendor/windows_x86_64_gnu-0.28.0/.cargo-checksum.json
@@ -0,0 +1 @@
+{"files":{"Cargo.toml":"7e36c48efcdf09bbb8cf5305ce57e7469cb984c81a0eba18bcecd635381a6e27","build.rs":"c446c74f57e8a30bd781b3bed930edc90f9c2897b7bddc635dc2c1adaf8e2353","lib/libwindows.a":"512289ae07f579ccb3f619425e231a08bb3c45d18830acfc8b772c572db12961","src/lib.rs":"01ba4719c80b6fe911b091a7c05124b64eeece964e09c058ef8f9805daca546b"},"package":"bc31f409f565611535130cfe7ee8e6655d3fa99c1c61013981e491921b5ce954"} \ No newline at end of file
diff --git a/vendor/windows_x86_64_gnu-0.28.0/Cargo.toml b/vendor/windows_x86_64_gnu-0.28.0/Cargo.toml
new file mode 100644
index 000000000..3d1ad5f5e
--- /dev/null
+++ b/vendor/windows_x86_64_gnu-0.28.0/Cargo.toml
@@ -0,0 +1,18 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "windows_x86_64_gnu"
+version = "0.28.0"
+authors = ["Microsoft"]
+description = "Code gen support for the windows crate"
+license = "MIT OR Apache-2.0"
diff --git a/vendor/windows_x86_64_gnu-0.28.0/build.rs b/vendor/windows_x86_64_gnu-0.28.0/build.rs
new file mode 100644
index 000000000..c968493dc
--- /dev/null
+++ b/vendor/windows_x86_64_gnu-0.28.0/build.rs
@@ -0,0 +1,9 @@
+fn main() {
+ if std::env::var("TARGET").unwrap() != "x86_64-pc-windows-gnu" {
+ return;
+ }
+
+ let dir = std::env::var("CARGO_MANIFEST_DIR").unwrap();
+
+ println!("cargo:rustc-link-search=native={}", std::path::Path::new(&dir).join("lib").display());
+}
diff --git a/vendor/windows_x86_64_gnu-0.28.0/lib/libwindows.a b/vendor/windows_x86_64_gnu-0.28.0/lib/libwindows.a
new file mode 100644
index 000000000..21699507a
--- /dev/null
+++ b/vendor/windows_x86_64_gnu-0.28.0/lib/libwindows.a
Binary files differ
diff --git a/vendor/windows_x86_64_gnu-0.28.0/src/lib.rs b/vendor/windows_x86_64_gnu-0.28.0/src/lib.rs
new file mode 100644
index 000000000..8b1378917
--- /dev/null
+++ b/vendor/windows_x86_64_gnu-0.28.0/src/lib.rs
@@ -0,0 +1 @@
+
diff --git a/vendor/windows_x86_64_gnu/.cargo-checksum.json b/vendor/windows_x86_64_gnu/.cargo-checksum.json
new file mode 100644
index 000000000..03829683f
--- /dev/null
+++ b/vendor/windows_x86_64_gnu/.cargo-checksum.json
@@ -0,0 +1 @@
+{"files":{"Cargo.toml":"cb87a36b3ade7c98a4e0e04bb7677051bc86cf10ae7db5a7830302d1dc859bd4","build.rs":"d1d816121af1bba70471e982bf98fa9cd2d8cf695d15d2837f592458410ff597","lib/libwindows.a":"441efa4700ce09c8fd1ac7b52dcf35398322e81bd83317081d78ed0608a06600","src/lib.rs":"bdf6c7cf1fc01f69cc1d4e52948d1f246fdd310e6323d5dd1efd23f1daf382ef"},"package":"4dcd171b8776c41b97521e5da127a2d86ad280114807d0b2ab1e462bc764d9e1"} \ No newline at end of file
diff --git a/vendor/windows_x86_64_gnu/Cargo.toml b/vendor/windows_x86_64_gnu/Cargo.toml
new file mode 100644
index 000000000..9ed2a23ee
--- /dev/null
+++ b/vendor/windows_x86_64_gnu/Cargo.toml
@@ -0,0 +1,23 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "windows_x86_64_gnu"
+version = "0.36.1"
+authors = ["Microsoft"]
+description = "Code gen support for the windows crate"
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/microsoft/windows-rs"
+
+[package.metadata.docs.rs]
+default-target = "x86_64-pc-windows-msvc"
+targets = []
diff --git a/vendor/windows_x86_64_gnu/build.rs b/vendor/windows_x86_64_gnu/build.rs
new file mode 100644
index 000000000..7612e7935
--- /dev/null
+++ b/vendor/windows_x86_64_gnu/build.rs
@@ -0,0 +1,10 @@
+fn main() {
+ let target = std::env::var("TARGET").unwrap();
+ if target != "x86_64-pc-windows-gnu" && target != "x86_64-uwp-windows-gnu" {
+ return;
+ }
+
+ let dir = std::env::var("CARGO_MANIFEST_DIR").unwrap();
+
+ println!("cargo:rustc-link-search=native={}", std::path::Path::new(&dir).join("lib").display());
+}
diff --git a/vendor/windows_x86_64_gnu/lib/libwindows.a b/vendor/windows_x86_64_gnu/lib/libwindows.a
new file mode 100644
index 000000000..64e8e9f45
--- /dev/null
+++ b/vendor/windows_x86_64_gnu/lib/libwindows.a
Binary files differ
diff --git a/vendor/windows_x86_64_gnu/src/lib.rs b/vendor/windows_x86_64_gnu/src/lib.rs
new file mode 100644
index 000000000..0c9ac1ac8
--- /dev/null
+++ b/vendor/windows_x86_64_gnu/src/lib.rs
@@ -0,0 +1 @@
+#![no_std]