summaryrefslogtreecommitdiffstats
path: root/vendor/xz2/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/xz2/Cargo.toml')
-rw-r--r--vendor/xz2/Cargo.toml54
1 files changed, 38 insertions, 16 deletions
diff --git a/vendor/xz2/Cargo.toml b/vendor/xz2/Cargo.toml
index 1971807cb..7cbb3480c 100644
--- a/vendor/xz2/Cargo.toml
+++ b/vendor/xz2/Cargo.toml
@@ -3,43 +3,65 @@
# When uploading crates to the registry Cargo will automatically
# "normalize" Cargo.toml files for maximal compatibility
# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g. crates.io) dependencies
+# to registry (e.g., crates.io) dependencies.
#
-# If you believe there's an error in this file please file an
-# issue against the rust-lang/cargo repository. If you're
-# editing this file be aware that the upstream Cargo.toml
-# will likely look very different (and much more reasonable)
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
[package]
+edition = "2018"
name = "xz2"
-version = "0.1.6"
+version = "0.1.7"
authors = ["Alex Crichton <alex@alexcrichton.com>"]
-description = "Rust bindings to liblzma providing Read/Write streams as well as low-level\nin-memory encoding/decoding.\n"
+description = """
+Rust bindings to liblzma providing Read/Write streams as well as low-level
+in-memory encoding/decoding.
+"""
homepage = "https://github.com/alexcrichton/xz2-rs"
documentation = "https://docs.rs/xz2"
readme = "README.md"
-keywords = ["lzma", "xz", "encoding"]
-categories = ["compression", "api-bindings"]
+keywords = [
+ "lzma",
+ "xz",
+ "encoding",
+]
+categories = [
+ "compression",
+ "api-bindings",
+]
license = "MIT/Apache-2.0"
repository = "https://github.com/alexcrichton/xz2-rs"
+
+[package.metadata.docs.rs]
+features = [
+ "tokio-io",
+ "futures",
+]
+
[dependencies.futures]
-version = "0.1"
+version = "0.1.26"
optional = true
[dependencies.lzma-sys]
-version = "0.1.11"
+version = "0.1.18"
[dependencies.tokio-io]
-version = "0.1"
+version = "0.1.12"
optional = true
+
[dev-dependencies.quickcheck]
-version = "0.7"
+version = "1.0.1"
[dev-dependencies.rand]
-version = "0.5"
+version = "0.8.0"
[dev-dependencies.tokio-core]
-version = "0.1"
+version = "0.1.17"
[features]
-tokio = ["tokio-io", "futures"]
+static = ["lzma-sys/static"]
+tokio = [
+ "tokio-io",
+ "futures",
+]