summaryrefslogtreecommitdiffstats
path: root/vendor/zerovec-derive/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/zerovec-derive/Cargo.toml')
-rw-r--r--vendor/zerovec-derive/Cargo.toml22
1 files changed, 16 insertions, 6 deletions
diff --git a/vendor/zerovec-derive/Cargo.toml b/vendor/zerovec-derive/Cargo.toml
index 667e6cc60..9ac0d2b2a 100644
--- a/vendor/zerovec-derive/Cargo.toml
+++ b/vendor/zerovec-derive/Cargo.toml
@@ -12,7 +12,7 @@
[package]
edition = "2021"
name = "zerovec-derive"
-version = "0.9.4"
+version = "0.10.0"
authors = ["Manish Goregaokar <manishsmail@gmail.com>"]
description = "Custom derive for the zerovec crate"
readme = "README.md"
@@ -29,7 +29,7 @@ categories = [
"no-std",
"data-structures",
]
-license = "Unicode-DFS-2016"
+license-file = "LICENSE"
repository = "https://github.com/unicode-org/icu4x"
[package.metadata.workspaces]
@@ -46,15 +46,13 @@ version = "1.0.27"
version = "1.0.9"
[dependencies.syn]
-version = "1.0.73"
+version = "2"
features = [
"derive",
"parsing",
+ "extra-traits",
]
-[dependencies.synstructure]
-version = "0.12.4"
-
[dev-dependencies.bincode]
version = "1.3"
@@ -64,3 +62,15 @@ features = ["derive"]
[dev-dependencies.serde_json]
version = "1.0"
+
+[dev-dependencies.zerofrom]
+version = "0.1.2"
+default-features = false
+
+[dev-dependencies.zerovec]
+version = ">=0.9.4, <0.11.0"
+features = [
+ "serde",
+ "derive",
+]
+default-features = false