summaryrefslogtreecommitdiffstats
path: root/vendor/zerovec-derive/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/zerovec-derive/Cargo.toml')
-rw-r--r--vendor/zerovec-derive/Cargo.toml66
1 files changed, 66 insertions, 0 deletions
diff --git a/vendor/zerovec-derive/Cargo.toml b/vendor/zerovec-derive/Cargo.toml
new file mode 100644
index 000000000..fea429984
--- /dev/null
+++ b/vendor/zerovec-derive/Cargo.toml
@@ -0,0 +1,66 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "zerovec-derive"
+version = "0.9.0"
+authors = ["Manish Goregaokar <manishsmail@gmail.com>"]
+description = "Custom derive for the zerovec crate"
+keywords = [
+ "zerocopy",
+ "serialization",
+ "zero-copy",
+ "serde",
+]
+categories = [
+ "rust-patterns",
+ "memory-management",
+ "caching",
+ "no-std",
+ "data-structures",
+]
+license = "Unicode-DFS-2016"
+repository = "https://github.com/unicode-org/icu4x"
+resolver = "2"
+
+[lib]
+path = "src/lib.rs"
+proc_macro = true
+
+[dependencies.proc-macro2]
+version = "1.0.27"
+
+[dependencies.quote]
+version = "1.0.9"
+
+[dependencies.syn]
+version = "1.0.73"
+features = [
+ "derive",
+ "parsing",
+]
+
+[dependencies.synstructure]
+version = "0.12.4"
+
+[dev-dependencies.bincode]
+version = "1.3"
+
+[dev-dependencies.serde]
+version = "1.0"
+features = ["derive"]
+
+[dev-dependencies.serde_json]
+version = "1.0"
+
+[dev-dependencies.zerofrom]
+version = "0.1"