summaryrefslogtreecommitdiffstats
path: root/vendor/zerovec/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--vendor/zerovec/Cargo.toml142
1 files changed, 142 insertions, 0 deletions
diff --git a/vendor/zerovec/Cargo.toml b/vendor/zerovec/Cargo.toml
new file mode 100644
index 000000000..2e305d302
--- /dev/null
+++ b/vendor/zerovec/Cargo.toml
@@ -0,0 +1,142 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+name = "zerovec"
+version = "0.9.0"
+authors = ["The ICU4X Project Developers"]
+include = [
+ "src/**/*",
+ "examples/**/*",
+ "benches/**/*",
+ "Cargo.toml",
+ "LICENSE",
+ "README.md",
+]
+description = "Zero-copy vector backed by a byte array"
+readme = "README.md"
+keywords = [
+ "zerocopy",
+ "serialization",
+ "zero-copy",
+ "serde",
+]
+categories = [
+ "rust-patterns",
+ "memory-management",
+ "caching",
+ "no-std",
+ "data-structures",
+]
+license = "Unicode-DFS-2016"
+repository = "https://github.com/unicode-org/icu4x"
+resolver = "2"
+
+[package.metadata.docs.rs]
+all-features = true
+
+[[example]]
+name = "zv_serde"
+required-features = ["serde"]
+
+[[bench]]
+name = "zerovec"
+harness = false
+
+[[bench]]
+name = "zerovec_serde"
+harness = false
+required-features = ["serde"]
+
+[[bench]]
+name = "vzv"
+harness = false
+
+[[bench]]
+name = "zerovec_iai"
+harness = false
+
+[[bench]]
+name = "zeromap"
+harness = false
+required-features = ["serde"]
+
+[dependencies.databake]
+version = "0.1.0"
+features = ["derive"]
+optional = true
+
+[dependencies.serde]
+version = "1.0"
+features = ["alloc"]
+optional = true
+default-features = false
+
+[dependencies.yoke]
+version = "0.6.0"
+optional = true
+
+[dependencies.zerofrom]
+version = "0.1.0"
+
+[dependencies.zerovec-derive]
+version = "0.9.0"
+optional = true
+
+[dev-dependencies.bincode]
+version = "1.3"
+
+[dev-dependencies.criterion]
+version = "0.3.4"
+
+[dev-dependencies.getrandom]
+version = "0.2"
+features = ["js"]
+
+[dev-dependencies.iai]
+version = "0.1"
+
+[dev-dependencies.icu_benchmark_macros]
+version = "0.7"
+
+[dev-dependencies.postcard]
+version = "1.0.0"
+features = ["use-std"]
+
+[dev-dependencies.rand]
+version = "0.8"
+
+[dev-dependencies.rand_distr]
+version = "0.4"
+
+[dev-dependencies.rand_pcg]
+version = "0.3"
+
+[dev-dependencies.serde]
+version = "1.0"
+features = ["derive"]
+
+[dev-dependencies.serde_json]
+version = "1.0"
+
+[dev-dependencies.yoke]
+version = "0.6.0"
+features = ["derive"]
+
+[dev-dependencies.zerofrom]
+version = "0.1.0"
+features = ["derive"]
+
+[features]
+bench = []
+derive = ["zerovec-derive"]
+std = []