summaryrefslogtreecommitdiffstats
path: root/vendor/zip/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/zip/Cargo.toml')
-rw-r--r--vendor/zip/Cargo.toml117
1 files changed, 117 insertions, 0 deletions
diff --git a/vendor/zip/Cargo.toml b/vendor/zip/Cargo.toml
new file mode 100644
index 000000000..7480ca9ea
--- /dev/null
+++ b/vendor/zip/Cargo.toml
@@ -0,0 +1,117 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "zip"
+version = "0.6.3"
+authors = [
+ "Mathijs van de Nes <git@mathijs.vd-nes.nl>",
+ "Marli Frost <marli@frost.red>",
+ "Ryan Levick <ryan.levick@gmail.com>",
+]
+description = """
+Library to support the reading and writing of zip files.
+"""
+keywords = [
+ "zip",
+ "archive",
+]
+license = "MIT"
+repository = "https://github.com/zip-rs/zip.git"
+
+[[bench]]
+name = "read_entry"
+harness = false
+
+[[bench]]
+name = "read_metadata"
+harness = false
+
+[dependencies.aes]
+version = "0.7.5"
+optional = true
+
+[dependencies.byteorder]
+version = "1.4.3"
+
+[dependencies.bzip2]
+version = "0.4.3"
+optional = true
+
+[dependencies.constant_time_eq]
+version = "0.1.5"
+optional = true
+
+[dependencies.crc32fast]
+version = "1.3.2"
+
+[dependencies.flate2]
+version = "1.0.23"
+optional = true
+default-features = false
+
+[dependencies.hmac]
+version = "0.12.1"
+features = ["reset"]
+optional = true
+
+[dependencies.pbkdf2]
+version = "0.11.0"
+optional = true
+
+[dependencies.sha1]
+version = "0.10.1"
+optional = true
+
+[dependencies.time]
+version = "0.3.7"
+features = [
+ "formatting",
+ "macros",
+]
+optional = true
+
+[dependencies.zstd]
+version = "0.11.0"
+optional = true
+
+[dev-dependencies.bencher]
+version = "0.1.5"
+
+[dev-dependencies.getrandom]
+version = "0.2.5"
+
+[dev-dependencies.walkdir]
+version = "2.3.2"
+
+[features]
+aes-crypto = [
+ "aes",
+ "constant_time_eq",
+ "hmac",
+ "pbkdf2",
+ "sha1",
+]
+default = [
+ "aes-crypto",
+ "bzip2",
+ "deflate",
+ "time",
+ "zstd",
+]
+deflate = ["flate2/rust_backend"]
+deflate-miniz = ["flate2/default"]
+deflate-zlib = ["flate2/zlib"]
+unreserved = []
+
+[target."cfg(any(all(target_arch = \"arm\", target_pointer_width = \"32\"), target_arch = \"mips\", target_arch = \"powerpc\"))".dependencies.crossbeam-utils]
+version = "0.8.8"