From 9918693037dce8aa4bb6f08741b6812923486c18 Mon Sep 17 00:00:00 2001
From: Daniel Baumann <daniel.baumann@progress-linux.org>
Date: Wed, 19 Jun 2024 11:26:03 +0200
Subject: Merging upstream version 1.76.0+dfsg1.

Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
---
 src/tools/rust-analyzer/crates/vfs-notify/Cargo.toml | 3 +--
 src/tools/rust-analyzer/crates/vfs-notify/src/lib.rs | 2 +-
 2 files changed, 2 insertions(+), 3 deletions(-)

(limited to 'src/tools/rust-analyzer/crates/vfs-notify')

diff --git a/src/tools/rust-analyzer/crates/vfs-notify/Cargo.toml b/src/tools/rust-analyzer/crates/vfs-notify/Cargo.toml
index 11055f028..fe6cb0a2c 100644
--- a/src/tools/rust-analyzer/crates/vfs-notify/Cargo.toml
+++ b/src/tools/rust-analyzer/crates/vfs-notify/Cargo.toml
@@ -12,10 +12,9 @@ rust-version.workspace = true
 doctest = false
 
 [dependencies]
-tracing = "0.1.35"
+tracing.workspace = true
 walkdir = "2.3.2"
 crossbeam-channel = "0.5.5"
-# We demand 5.1.0 as any higher version pulls in a new windows-sys dupe
 notify = "6.1.1"
 
 stdx.workspace = true
diff --git a/src/tools/rust-analyzer/crates/vfs-notify/src/lib.rs b/src/tools/rust-analyzer/crates/vfs-notify/src/lib.rs
index abfc51dfe..030650437 100644
--- a/src/tools/rust-analyzer/crates/vfs-notify/src/lib.rs
+++ b/src/tools/rust-analyzer/crates/vfs-notify/src/lib.rs
@@ -7,7 +7,7 @@
 //! Hopefully, one day a reliable file watching/walking crate appears on
 //! crates.io, and we can reduce this to trivial glue code.
 
-#![warn(rust_2018_idioms, unused_lifetimes, semicolon_in_expressions_from_macros)]
+#![warn(rust_2018_idioms, unused_lifetimes)]
 
 use std::fs;
 
-- 
cgit v1.2.3