summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-26 16:05:46 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-26 16:05:46 +0000
commitfc8c6561af3fc6d2a44359611b7cb57df917c70c (patch)
tree4330af4fc1694fec9fd04eb5227e784b0a3d0409
parentAdding debian version 2:4.20.2+dfsg-1. (diff)
downloadsamba-fc8c6561af3fc6d2a44359611b7cb57df917c70c.tar.xz
samba-fc8c6561af3fc6d2a44359611b7cb57df917c70c.zip
Adding debian version 2:4.20.2+dfsg-2.debian/2%4.20.2+dfsg-2
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
-rw-r--r--debian/changelog6
-rw-r--r--debian/patches/series1
-rw-r--r--debian/patches/tilde-in-version.diff23
3 files changed, 30 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index e27e40d..586859d 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+samba (2:4.20.2+dfsg-2) unstable; urgency=medium
+
+ * tilde-in-version.diff - allow tilde in version string
+
+ -- Michael Tokarev <mjt@tls.msk.ru> Thu, 20 Jun 2024 09:49:50 +0300
+
samba (2:4.20.2+dfsg-1) unstable; urgency=medium
* new upstream stable/bugfix release:
diff --git a/debian/patches/series b/debian/patches/series
index 681595b..c469cbc 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -26,3 +26,4 @@ edns0.patch
passchange-error-message.patch
lower-dns-lookup-mismatch-messages.patch
make-python-optional.diff
+tilde-in-version.diff
diff --git a/debian/patches/tilde-in-version.diff b/debian/patches/tilde-in-version.diff
new file mode 100644
index 0000000..8182935
--- /dev/null
+++ b/debian/patches/tilde-in-version.diff
@@ -0,0 +1,23 @@
+From: Michael Tokarev <mjt@tls.msk.ru>
+Subject: handle tilde in version string
+Date: Thu, 20 Jun 2024 09:47:47 +0300
+Forwarded: yes
+
+wafsamba dislikes when version string contains "special" chars.
+For some of them, upstream already has code to deal with.
+Add handling of tilde (~) to the same places too.
+
+diff --git a/buildtools/wafsamba/samba_abi.py b/buildtools/wafsamba/samba_abi.py
+index 2d9505d255c..cf7153f25f0 100644
+--- a/buildtools/wafsamba/samba_abi.py
++++ b/buildtools/wafsamba/samba_abi.py
+@@ -288,3 +288,3 @@ def abi_build_vscript(task):
+ def VSCRIPT_MAP_PRIVATE(bld, libname, orig_vscript, version, private_vscript):
+- version = version.replace("-", "_").replace("+","_").upper()
++ version = version.replace("-", "_").replace("+","_").replace("~","_").upper()
+ t = bld.SAMBA_GENERATOR(private_vscript,
+@@ -317,3 +317,3 @@ def ABI_VSCRIPT(bld, libname, abi_directory, version, vscript, abi_match=None, p
+ libname = libname.replace("-", "_").replace("+","_").upper()
+- version = version.replace("-", "_").replace("+","_").upper()
++ version = version.replace("-", "_").replace("+","_").replace("~","_").upper()
+