summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-08 13:04:46 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-08 13:04:46 +0000
commit686a7454a54dee5eebf8d3d1bc9e16a5917beec9 (patch)
treeb74743547fc5d7aa62cc526ea62b61e5ac043712 /debian/rules
parentMerging upstream version 2:4.20.1+dfsg. (diff)
downloadsamba-686a7454a54dee5eebf8d3d1bc9e16a5917beec9.tar.xz
samba-686a7454a54dee5eebf8d3d1bc9e16a5917beec9.zip
Merging debian version 2:4.20.1+dfsg-1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rwxr-xr-xdebian/rules9
1 files changed, 8 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 9fd250e..bd00724 100755
--- a/debian/rules
+++ b/debian/rules
@@ -122,7 +122,7 @@ config-args += $(if ${with-ceph},\
--enable-cephfs --enable-ceph-reclock,\
--disable-cephfs)
-# we had t64 transition (libsmbclient => libsmbclient0) before trixie
+# we had t64 transition (libsmbclient => libsmbclient0) for trixie
ifneq (,$(filter pkg.samba.before-trixie, ${DEB_BUILD_PROFILES}))
libsmbclient := libsmbclient
else
@@ -162,6 +162,12 @@ install install-arch install-indep: %:
configure: bin/configured.stamp
.PHONY: configure
bin/configured.stamp:
+# branding
+ if [ ! -f VERSION.orig ]; then \
+ mv VERSION VERSION.orig; \
+ sed -r -e 's/^(SAMBA_VERSION_VENDOR_SUFFIX).*/\1=${DEB_VENDOR}/' \
+ VERSION.orig > VERSION; \
+ fi
CC="${CC}" CPP="${CPP}" LD="${LD}" PKGCONFIG="${PKG_CONFIG}" \
CPPFLAGS="${CPPFLAGS}" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" \
PYTHON=python3 PYTHON_CONFIG=${DEB_HOST_MULTIARCH}-python3-config \
@@ -393,6 +399,7 @@ endif
clean:
# see also debian/clean
dh_clean bin/ testbuild/
+ [ ! -f VERSION.orig ] || mv -f VERSION.orig VERSION
ifneq (,${with_mitkrb5})
[ ! -d third_party/heimdal-build-with-mitkrb5 ] || \
mv third_party/heimdal-build-with-mitkrb5 third_party/heimdal