summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 17:29:03 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 17:30:32 +0000
commit5eecad626013c2b5a6e0c98729df43e7f563b01e (patch)
tree13f303699c880caf06fd8d813d14dd6de8fa0480 /debian/rules
parentReleasing progress-linux version 2:4.20.0+dfsg-1~exp1~progress7.99u1. (diff)
downloadsamba-5eecad626013c2b5a6e0c98729df43e7f563b01e.tar.xz
samba-5eecad626013c2b5a6e0c98729df43e7f563b01e.zip
Merging debian version 2:4.20.0+dfsg-1~exp2.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rwxr-xr-xdebian/rules18
1 files changed, 9 insertions, 9 deletions
diff --git a/debian/rules b/debian/rules
index 9428597..eb4e838 100755
--- a/debian/rules
+++ b/debian/rules
@@ -120,6 +120,13 @@ config-args += $(if ${with-ceph},\
--enable-cephfs --enable-ceph-reclock,\
--disable-cephfs)
+# we had t64 transition (libsmbclient => libsmbclient0) before trixie
+ifneq (,$(filter pkg.samba.before-trixie, ${DEB_BUILD_PROFILES}))
+libsmbclient := libsmbclient
+else
+libsmbclient := libsmbclient0
+endif
+
with_mitkrb5 = $(filter pkg.samba.mitkrb5, ${DEB_BUILD_PROFILES})
ifneq (,${with_mitkrb5})
config-args += \
@@ -131,7 +138,7 @@ mitkrb5-samba-ver = ${DEB_VERSION}mitkrb5
mitkrb5-dep-pkgs = samba-libs samba-dev
mitkrb5-dep-pkgs += samba samba-common-bin python3-samba
mitkrb5-dep-pkgs += samba-dsdb-modules samba-vfs-modules
-mitkrb5-dep-pkgs += libsmbclient smbclient
+mitkrb5-dep-pkgs += ${libsmbclient} smbclient
mitkrb5-dep-pkgs += libnss-winbind libpam-winbind
mitkrb5-dep-pkgs += winbind libwbclient0
mitkrb5-dep-pkgs += samba-testsuite
@@ -153,12 +160,6 @@ install install-arch install-indep: %:
configure: bin/configured.stamp
.PHONY: configure
bin/configured.stamp:
-# branding
- if [ ! -f VERSION.orig ]; then \
- mv VERSION VERSION.orig; \
- sed -r -e 's/^(SAMBA_VERSION_VENDOR_SUFFIX).*/\1=${DEB_VENDOR}/' \
- VERSION.orig > VERSION; \
- fi
CC="${CC}" CPP="${CPP}" LD="${LD}" PKGCONFIG="${PKG_CONFIG}" \
CPPFLAGS="${CPPFLAGS}" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" \
PYTHON=python3 PYTHON_CONFIG=${DEB_HOST_MULTIARCH}-python3-config \
@@ -376,7 +377,7 @@ endif
$(call depcheck, libldb2, samba|samba-libs|winbind|libwbclient0) # use-bzero-instead-of-memset_s.diff
$(call depcheck, python3-samba, samba|winbind|ctdb)
$(call depcheck, libwbclient0, samba|samba-libs|winbind|smbclient|ctdb)
- $(call depcheck, libsmbclient, samba|winbind|smbclient|ctdb)
+ $(call depcheck, ${libsmbclient}, samba|winbind|smbclient|ctdb)
override_dh_gencontrol:
dh_gencontrol $(addprefix -p, ${LDB_PACKAGES}) -- -v${LDB_DEB_VERSION}
@@ -390,7 +391,6 @@ endif
clean:
# see also debian/clean
dh_clean bin/ testbuild/
- [ ! -f VERSION.orig ] || mv -f VERSION.orig VERSION
ifneq (,${with_mitkrb5})
[ ! -d third_party/heimdal-build-with-mitkrb5 ] || \
mv third_party/heimdal-build-with-mitkrb5 third_party/heimdal