summaryrefslogtreecommitdiffstats
path: root/lib/pthreadpool/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lib/pthreadpool/Makefile')
-rw-r--r--lib/pthreadpool/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/lib/pthreadpool/Makefile b/lib/pthreadpool/Makefile
new file mode 100644
index 0000000..48626bd
--- /dev/null
+++ b/lib/pthreadpool/Makefile
@@ -0,0 +1,9 @@
+all: tests
+
+CFLAGS=-O3 -g -Wall
+
+pthreadpool.o: pthreadpool.c pthreadpool.h
+ gcc -c -O3 -o pthreadpool.o pthreadpool.c -I../../..
+
+tests: tests.o pthreadpool.o
+ gcc -o tests tests.o pthreadpool.o -lpthread \ No newline at end of file