summaryrefslogtreecommitdiffstats
path: root/third_party/heimdal/tests/bin/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/heimdal/tests/bin/Makefile.am')
-rw-r--r--third_party/heimdal/tests/bin/Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/third_party/heimdal/tests/bin/Makefile.am b/third_party/heimdal/tests/bin/Makefile.am
new file mode 100644
index 0000000..98bb342
--- /dev/null
+++ b/third_party/heimdal/tests/bin/Makefile.am
@@ -0,0 +1,30 @@
+include $(top_srcdir)/Makefile.am.common
+
+noinst_SCRIPTS = setup-env
+
+noinst_PROGRAMS = intr
+
+intr_SOURCES = intr.c
+
+CHECK_LOCAL = no-check-local
+
+intr_LDADD = $(LIB_roken)
+
+do_subst = \
+ top_srcdir="$$(cd ${top_srcdir} && pwd)" ; \
+ top_builddir="$$(cd ${top_builddir} && pwd)" ; \
+ sed $(do_dlopen) \
+ -e "s,[@]EGREP[@],$(EGREP),g" \
+ -e "s,[@]top_srcdir[@],$${top_srcdir},g" \
+ -e "s,[@]top_builddir[@],$${top_builddir},g" \
+ -e "s,[@]NO_AFS[@],$(NO_AFS),g"
+
+setup-env: setup-env.in Makefile
+ $(do_subst) < $(srcdir)/setup-env.in > setup-env.tmp
+ chmod +x setup-env.tmp
+ mv setup-env.tmp setup-env
+
+EXTRA_DIST = setup-env.in
+
+CLEANFILES = setup-env setup-env.tmp
+