summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 03:26:43 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 03:26:43 +0000
commitd52610ef3e6fe0a00077e2ccd4e7728977ae663d (patch)
treef13721f52fed4506167686221510ae1c338053c6 /debian/rules
parentAdding upstream version 0.8.7. (diff)
downloadsexpp-d52610ef3e6fe0a00077e2ccd4e7728977ae663d.tar.xz
sexpp-d52610ef3e6fe0a00077e2ccd4e7728977ae663d.zip
Adding debian version 0.8.7-3.1.debian/0.8.7-3.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rwxr-xr-xdebian/rules18
1 files changed, 18 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..fd6a449
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,18 @@
+#!/usr/bin/make -f
+
+include /usr/share/dpkg/pkg-info.mk
+export DEB_VERSION
+
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+
+CONFIGURE_OPTIONS = -DBUILD_SHARED_LIBS=on
+
+ifneq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
+CONFIGURE_OPTIONS += -DWITH_SEXP_TESTS=off
+endif
+
+override_dh_auto_configure:
+ dh_auto_configure --builddirectory=build -- $(CONFIGURE_OPTIONS)
+
+%:
+ dh $@ --builddirectory=build