summaryrefslogtreecommitdiffstats
path: root/debian/patches/0001-Fetch-Googletest-from-local-package-installation.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/0001-Fetch-Googletest-from-local-package-installation.patch')
-rw-r--r--debian/patches/0001-Fetch-Googletest-from-local-package-installation.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/debian/patches/0001-Fetch-Googletest-from-local-package-installation.patch b/debian/patches/0001-Fetch-Googletest-from-local-package-installation.patch
new file mode 100644
index 0000000..26d0295
--- /dev/null
+++ b/debian/patches/0001-Fetch-Googletest-from-local-package-installation.patch
@@ -0,0 +1,23 @@
+From: Daniel Kahn Gillmor <dkg@fifthhorseman.net>
+Date: Tue, 20 Jun 2023 10:55:38 -0400
+Subject: Fetch Googletest from local package installation
+
+Forwarded: not-needed
+---
+ CMakeLists.txt | 3 +--
+ 1 file changed, 1 insertion(+), 2 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 9ac363c..eb863d2 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -210,8 +210,7 @@ if(WITH_SEXP_TESTS)
+ include(FetchContent)
+ FetchContent_Declare(
+ googletest
+- GIT_REPOSITORY https://github.com/google/googletest.git
+- GIT_TAG ${GTEST_TAG}
++ SOURCE_DIR /usr/src/googletest
+ )
+ # maintain compiler/linker settings on Windows
+ set(gtest_force_shared_crt ON CACHE BOOL "" FORCE)