summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-26 16:20:26 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-26 16:20:26 +0000
commit06cf122aaf0b00d5e4bdd9f88550bb355735fb5d (patch)
tree7aa2d5b4df2ca9de14ba4e46f153dba4b8911f37 /debian/rules
parentAdding debian version 1:4.15.2-1. (diff)
downloadshadow-debian/1%4.15.2-2.tar.xz
shadow-debian/1%4.15.2-2.zip
Adding debian version 1:4.15.2-2.debian/1%4.15.2-2
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rwxr-xr-xdebian/rules6
1 files changed, 2 insertions, 4 deletions
diff --git a/debian/rules b/debian/rules
index ad27cdf..7d20ba6 100755
--- a/debian/rules
+++ b/debian/rules
@@ -13,6 +13,7 @@ DEB_CONFIGURE_EXTRA_FLAGS := \
--with-libpam \
--with-yescrypt \
--enable-shadowgrp \
+ --enable-subordinate-ids \
--enable-lastlog=no \
--enable-man \
--disable-account-tools-setuid \
@@ -25,6 +26,7 @@ DEB_CONFIGURE_EXTRA_FLAGS := \
ifneq ($(DEB_HOST_ARCH_OS),linux)
DEB_CONFIGURE_EXTRA_FLAGS += --enable-logind
+DEB_CONFIGURE_EXTRA_FLAGS += --with-audit
endif
ifneq ($(filter nodoc,$(DEB_BUILD_PROFILES)),)
@@ -40,7 +42,6 @@ CFLAGS += -DDEFAULT_EDITOR="\"sensible-editor\""
dh $@
override_dh_auto_configure:
- cp debian/HOME_MODE.xml man/login.defs.d/HOME_MODE.xml
dh_auto_configure -- $(DEB_CONFIGURE_EXTRA_FLAGS)
override_dh_install-arch:
@@ -66,6 +67,3 @@ override_dh_installpam:
override_dh_auto_clean:
sed -i 's/# Linux only # //' debian/login.pam
dh_auto_clean
-
-override_dh_clean:
- dh_clean ./man/login.defs.d/HOME_MODE.xml