summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-26 16:18:38 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-26 16:18:38 +0000
commit37112ff6dd482edb8af60f110971e4c91d035f30 (patch)
tree30de6e55c07318a1321a213719470f542513c768 /debian/rules
parentMerging upstream version 1:4.15.2. (diff)
downloadshadow-37112ff6dd482edb8af60f110971e4c91d035f30.tar.xz
shadow-37112ff6dd482edb8af60f110971e4c91d035f30.zip
Adding debian version 1:4.15.2-1.debian/1%4.15.2-1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules16
1 files changed, 12 insertions, 4 deletions
diff --git a/debian/rules b/debian/rules
index 6256182..ad27cdf 100755
--- a/debian/rules
+++ b/debian/rules
@@ -5,26 +5,34 @@
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
DPKG_EXPORT_BUILDFLAGS = 1
include /usr/share/dpkg/buildflags.mk
+include /usr/share/debhelper/dh_package_notes/package-notes.mk
# Adds extra options when calling the configure script:
-DEB_CONFIGURE_EXTRA_FLAGS := --without-libcrack \
+DEB_CONFIGURE_EXTRA_FLAGS := \
--mandir=/usr/share/man \
--with-libpam \
--with-yescrypt \
--enable-shadowgrp \
+ --enable-lastlog=no \
--enable-man \
--disable-account-tools-setuid \
--with-group-name-max-length=32 \
- --without-acl \
- --without-attr \
+ --with-acl \
+ --with-attr \
--without-su \
--without-tcb \
- SHELL=/bin/sh
+
+
+ifneq ($(DEB_HOST_ARCH_OS),linux)
+DEB_CONFIGURE_EXTRA_FLAGS += --enable-logind
+endif
ifneq ($(filter nodoc,$(DEB_BUILD_PROFILES)),)
DEB_CONFIGURE_EXTRA_FLAGS += --disable-man
endif
+DEB_CONFIGURE_EXTRA_FLAGS += SHELL=/bin/sh
+
# Set the default editor for vipw/vigr
CFLAGS += -DDEFAULT_EDITOR="\"sensible-editor\""