summaryrefslogtreecommitdiffstats
path: root/doc/console.c.spec.txt
diff options
context:
space:
mode:
Diffstat (limited to 'doc/console.c.spec.txt')
-rw-r--r--doc/console.c.spec.txt36
1 files changed, 0 insertions, 36 deletions
diff --git a/doc/console.c.spec.txt b/doc/console.c.spec.txt
deleted file mode 100644
index b7c0d0d..0000000
--- a/doc/console.c.spec.txt
+++ /dev/null
@@ -1,36 +0,0 @@
-$Id$
-
-Specification for console.c source file --
-
-input values --
- tty -- character pointer to device name with leading "/dev/"
- removed.
-
-return values --
- 0 -- false
- 1 -- true
-
-int console (char * tty)
- if "CONSOLE" string value is not present in login.defs
- return true
-
- if the first character of "CONSOLE" string value is not "/"
- treat the string as a ":" delimited list of device
- names and search for the value of tty in that
- tokenized list.
-
- if a match is found
- return true
-
- return false
-
- if the file named by "CONSOLE" cannot be opened
- return true
-
- scan the file looking for a match between the input line
- and the value of tty
-
- if a match is found
- return true
-
- return false