summaryrefslogtreecommitdiffstats
path: root/debian/patches
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 17:25:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 17:25:44 +0000
commite20628db512128d3a5c66360943462b83da5f049 (patch)
treed0c586bb2b3ce26a240c5fb0765982ce87d53816 /debian/patches
parentAdding upstream version 7.2.6. (diff)
downloadsphinx-e20628db512128d3a5c66360943462b83da5f049.tar.xz
sphinx-e20628db512128d3a5c66360943462b83da5f049.zip
Adding debian version 7.2.6-6.debian/7.2.6-6
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/docutils_manpage_macros.diff22
-rw-r--r--debian/patches/intersphinx_local.diff51
-rw-r--r--debian/patches/move_sphinxcontrib_to_extras_require.diff40
-rw-r--r--debian/patches/no_external_css.diff21
-rw-r--r--debian/patches/python_3.11.7.diff77
-rw-r--r--debian/patches/remove_contrib_references.diff79
-rw-r--r--debian/patches/series11
-rw-r--r--debian/patches/skip_tests_jsmath.diff36
-rw-r--r--debian/patches/skip_tests_network.diff21
-rw-r--r--debian/patches/skip_tests_serializinghtml.diff28
-rw-r--r--debian/patches/support_old_search_indexes.diff48
-rw-r--r--debian/patches/use_packaged_mathjax.diff20
12 files changed, 454 insertions, 0 deletions
diff --git a/debian/patches/docutils_manpage_macros.diff b/debian/patches/docutils_manpage_macros.diff
new file mode 100644
index 0000000..4bf22dc
--- /dev/null
+++ b/debian/patches/docutils_manpage_macros.diff
@@ -0,0 +1,22 @@
+From: Dmitry Shachnev <mitya57@debian.org>
+Date: Thu, 3 Aug 2023 19:23:41 +0300
+Subject: Make test_build_manpage pass with docutils 0.19+dfsg-7
+
+I backported the change from upstream 0.21 to our 0.19 and 0.20 packaging.
+---
+ tests/test_build_manpage.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/tests/test_build_manpage.py b/tests/test_build_manpage.py
+index e765644..2fc2014 100644
+--- a/tests/test_build_manpage.py
++++ b/tests/test_build_manpage.py
+@@ -52,7 +52,7 @@ def test_captioned_code_block(app, status, warning):
+ app.builder.build_all()
+ content = (app.outdir / 'python.1').read_text(encoding='utf8')
+
+- if docutils.__version_info__[:2] < (0, 21):
++ if docutils.__version_info__[:2] < (0, 19):
+ expected = """\
+ .sp
+ caption \\fItest\\fP rb
diff --git a/debian/patches/intersphinx_local.diff b/debian/patches/intersphinx_local.diff
new file mode 100644
index 0000000..1eff330
--- /dev/null
+++ b/debian/patches/intersphinx_local.diff
@@ -0,0 +1,51 @@
+From: Dmitry Shachnev <mitya57@debian.org>
+Date: Tue, 2 Jun 2020 12:22:52 +0300
+Subject: Use local intersphinx inventory
+
+To prevent Sphinx from downloading https://docs.python.org/3/objects.inv
+during build.
+---
+ doc/conf.py | 5 ++---
+ doc/tutorial/deploying.rst | 9 ++++++---
+ 2 files changed, 8 insertions(+), 6 deletions(-)
+
+diff --git a/doc/conf.py b/doc/conf.py
+index 416158f..a262354 100644
+--- a/doc/conf.py
++++ b/doc/conf.py
+@@ -117,9 +117,8 @@ texinfo_documents = [
+ ]
+
+ intersphinx_mapping = {
+- 'python': ('https://docs.python.org/3/', None),
+- 'requests': ('https://requests.readthedocs.io/en/latest/', None),
+- 'readthedocs': ('https://docs.readthedocs.io/en/stable', None),
++ 'python': ('/usr/share/doc/python3-doc/html', None),
++ 'requests': ('/usr/share/doc/python-requests-doc/html', None),
+ }
+
+ # Sphinx document translation with sphinx gettext feature uses these settings:
+diff --git a/doc/tutorial/deploying.rst b/doc/tutorial/deploying.rst
+index e16abdf..1c4e3c6 100644
+--- a/doc/tutorial/deploying.rst
++++ b/doc/tutorial/deploying.rst
+@@ -160,13 +160,16 @@ Read the Docs
+ ~~~~~~~~~~~~~
+
+ `Read the Docs`_ offers integration with both GitHub and GitLab. The quickest
+-way of getting started is to follow :doc:`the RTD
+-tutorial <readthedocs:tutorial/index>`, which is loosely based on this one.
++way of getting started is to follow `the RTD tutorial`_, which is loosely
++based on this one.
+ You can publish your sources on GitHub as explained :ref:`in the previous
+ section <publishing-sources>`, then skip directly to
+-:ref:`readthedocs:tutorial/index:Sign up for Read the Docs`.
++`Sign up for Read the Docs`_.
+ If you choose GitLab instead, the process is similar.
+
++.. _the RTD tutorial: https://docs.readthedocs.io/en/stable/tutorial/index.html
++.. _Sign up for Read the Docs: https://docs.readthedocs.io/en/stable/tutorial/index.html#sign-up-for-read-the-docs
++
+ GitHub Pages
+ ~~~~~~~~~~~~
+
diff --git a/debian/patches/move_sphinxcontrib_to_extras_require.diff b/debian/patches/move_sphinxcontrib_to_extras_require.diff
new file mode 100644
index 0000000..9fa47ea
--- /dev/null
+++ b/debian/patches/move_sphinxcontrib_to_extras_require.diff
@@ -0,0 +1,40 @@
+From: Dmitry Shachnev <mitya57@debian.org>
+Date: Fri, 7 Feb 2020 13:59:30 +0300
+Subject: Move sphinxcontrib modules to extras_require
+
+---
+ pyproject.toml | 14 ++++++++------
+ 1 file changed, 8 insertions(+), 6 deletions(-)
+
+diff --git a/pyproject.toml b/pyproject.toml
+index 0a9bc9e..6383e31 100644
+--- a/pyproject.toml
++++ b/pyproject.toml
+@@ -55,12 +55,6 @@ classifiers = [
+ "Topic :: Utilities",
+ ]
+ dependencies = [
+- "sphinxcontrib-applehelp",
+- "sphinxcontrib-devhelp",
+- "sphinxcontrib-jsmath",
+- "sphinxcontrib-htmlhelp>=2.0.0",
+- "sphinxcontrib-serializinghtml>=1.1.9",
+- "sphinxcontrib-qthelp",
+ "Jinja2>=3.0",
+ "Pygments>=2.14",
+ "docutils>=0.18.1,<0.21",
+@@ -96,6 +90,14 @@ test = [
+ "setuptools>=67.0", # for Cython compilation
+ "filelock",
+ ]
++sphinxcontrib = [
++ "sphinxcontrib-applehelp",
++ "sphinxcontrib-devhelp",
++ "sphinxcontrib-jsmath",
++ "sphinxcontrib-htmlhelp>=2.0.0",
++ "sphinxcontrib-serializinghtml>=1.1.9",
++ "sphinxcontrib-qthelp",
++]
+
+ [[project.authors]]
+ name = "Georg Brandl"
diff --git a/debian/patches/no_external_css.diff b/debian/patches/no_external_css.diff
new file mode 100644
index 0000000..697de83
--- /dev/null
+++ b/debian/patches/no_external_css.diff
@@ -0,0 +1,21 @@
+From: Chris Lamb <lamby@debian.org>
+Date: Sat, 14 Apr 2018 10:10:45 +0100
+Subject: Don't use Google Fonts to avoid privacy breach.
+
+---
+ sphinx/themes/pyramid/layout.html | 2 --
+ 1 file changed, 2 deletions(-)
+
+diff --git a/sphinx/themes/pyramid/layout.html b/sphinx/themes/pyramid/layout.html
+index ffa9313..19f351d 100644
+--- a/sphinx/themes/pyramid/layout.html
++++ b/sphinx/themes/pyramid/layout.html
+@@ -1,8 +1,6 @@
+ {%- extends "basic/layout.html" %}
+
+ {%- block extrahead %}
+-<link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Neuton&amp;subset=latin" type="text/css" media="screen" charset="utf-8" />
+-<link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Nobile:regular,italic,bold,bolditalic&amp;subset=latin" type="text/css" media="screen" charset="utf-8" />
+ <!--[if lte IE 6]>
+ <link rel="stylesheet" href="{{ pathto('_static/ie6.css', 1) }}" type="text/css" media="screen" charset="utf-8" />
+ <![endif]-->
diff --git a/debian/patches/python_3.11.7.diff b/debian/patches/python_3.11.7.diff
new file mode 100644
index 0000000..02ed97f
--- /dev/null
+++ b/debian/patches/python_3.11.7.diff
@@ -0,0 +1,77 @@
+From: Hugo van Kemenade <hugovk@users.noreply.github.com>
+Date: Mon, 11 Dec 2023 12:01:55 +0200
+Subject: Fix autodoc tests for Python 3.11.7+
+
+Origin: https://github.com/sphinx-doc/sphinx/pull/11793
+---
+ tests/test_ext_autodoc_configs.py | 24 ++++++++++++++++++++----
+ 1 file changed, 20 insertions(+), 4 deletions(-)
+
+diff --git a/tests/test_ext_autodoc_configs.py b/tests/test_ext_autodoc_configs.py
+index 45bc729..2e8f40c 100644
+--- a/tests/test_ext_autodoc_configs.py
++++ b/tests/test_ext_autodoc_configs.py
+@@ -1584,6 +1584,14 @@ def test_autodoc_typehints_format_fully_qualified_for_newtype_alias(app):
+
+ @pytest.mark.sphinx('html', testroot='ext-autodoc')
+ def test_autodoc_default_options(app):
++ if (
++ (3, 11, 7) <= sys.version_info < (3, 12)
++ or sys.version_info >= (3, 12, 1)
++ ):
++ list_of_weak_references = " list of weak references to the object"
++ else:
++ list_of_weak_references = " list of weak references to the object (if defined)"
++
+ # no settings
+ actual = do_autodoc(app, 'class', 'target.enums.EnumCls')
+ assert ' .. py:attribute:: EnumCls.val1' not in actual
+@@ -1627,7 +1635,7 @@ def test_autodoc_default_options(app):
+ assert ' Iterate squares of each value.' in actual
+ if not IS_PYPY:
+ assert ' .. py:attribute:: CustomIter.__weakref__' in actual
+- assert ' list of weak references to the object (if defined)' in actual
++ assert list_of_weak_references in actual
+
+ # :exclude-members: None - has no effect. Unlike :members:,
+ # :special-members:, etc. where None == "include all", here None means
+@@ -1651,13 +1659,21 @@ def test_autodoc_default_options(app):
+ assert ' Iterate squares of each value.' in actual
+ if not IS_PYPY:
+ assert ' .. py:attribute:: CustomIter.__weakref__' in actual
+- assert ' list of weak references to the object (if defined)' in actual
++ assert list_of_weak_references in actual
+ assert ' .. py:method:: CustomIter.snafucate()' in actual
+ assert ' Makes this snafucated.' in actual
+
+
+ @pytest.mark.sphinx('html', testroot='ext-autodoc')
+ def test_autodoc_default_options_with_values(app):
++ if (
++ (3, 11, 7) <= sys.version_info < (3, 12)
++ or sys.version_info >= (3, 12, 1)
++ ):
++ list_of_weak_references = " list of weak references to the object"
++ else:
++ list_of_weak_references = " list of weak references to the object (if defined)"
++
+ # with :members:
+ app.config.autodoc_default_options = {'members': 'val1,val2'}
+ actual = do_autodoc(app, 'class', 'target.enums.EnumCls')
+@@ -1698,7 +1714,7 @@ def test_autodoc_default_options_with_values(app):
+ assert ' Iterate squares of each value.' in actual
+ if not IS_PYPY:
+ assert ' .. py:attribute:: CustomIter.__weakref__' not in actual
+- assert ' list of weak references to the object (if defined)' not in actual
++ assert list_of_weak_references not in actual
+
+ # with :exclude-members:
+ app.config.autodoc_default_options = {
+@@ -1722,6 +1738,6 @@ def test_autodoc_default_options_with_values(app):
+ assert ' Iterate squares of each value.' in actual
+ if not IS_PYPY:
+ assert ' .. py:attribute:: CustomIter.__weakref__' not in actual
+- assert ' list of weak references to the object (if defined)' not in actual
++ assert list_of_weak_references not in actual
+ assert ' .. py:method:: CustomIter.snafucate()' not in actual
+ assert ' Makes this snafucated.' not in actual
diff --git a/debian/patches/remove_contrib_references.diff b/debian/patches/remove_contrib_references.diff
new file mode 100644
index 0000000..8510649
--- /dev/null
+++ b/debian/patches/remove_contrib_references.diff
@@ -0,0 +1,79 @@
+From: Dmitry Shachnev <mitya57@debian.org>
+Date: Wed, 25 Dec 2019 23:18:56 +0300
+Subject: Remove references to sphinxcontrib modules
+
+They are not packaged yet, and when they are, we would want to avoid
+dependency loops anyway.
+---
+ doc/usage/builders/index.rst | 24 ------------------------
+ sphinx/application.py | 1 -
+ 2 files changed, 25 deletions(-)
+
+diff --git a/doc/usage/builders/index.rst b/doc/usage/builders/index.rst
+index ce2c5dc..01172a7 100644
+--- a/doc/usage/builders/index.rst
++++ b/doc/usage/builders/index.rst
+@@ -68,12 +68,6 @@ The builder's "name" must be given to the **-b** command-line option of
+ also generates HTML Help support files that allow the Microsoft HTML Help
+ Workshop to compile them into a CHM file.
+
+- .. autoattribute:: name
+-
+- .. autoattribute:: format
+-
+- .. autoattribute:: supported_image_types
+-
+ .. module:: sphinxcontrib.qthelp
+ .. class:: QtHelpBuilder
+
+@@ -85,12 +79,6 @@ The builder's "name" must be given to the **-b** command-line option of
+
+ Moved to sphinxcontrib.qthelp from sphinx.builders package.
+
+- .. autoattribute:: name
+-
+- .. autoattribute:: format
+-
+- .. autoattribute:: supported_image_types
+-
+ .. _Qt help: https://doc.qt.io/qt-4.8/qthelp-framework.html
+
+ .. module:: sphinxcontrib.applehelp
+@@ -111,12 +99,6 @@ The builder's "name" must be given to the **-b** command-line option of
+ output will not be valid until :program:`hiutil` has been run on all of the
+ ``.lproj`` folders within the bundle.
+
+- .. autoattribute:: name
+-
+- .. autoattribute:: format
+-
+- .. autoattribute:: supported_image_types
+-
+ .. versionadded:: 1.3
+
+ .. versionchanged:: 2.0
+@@ -130,12 +112,6 @@ The builder's "name" must be given to the **-b** command-line option of
+ also generates `GNOME Devhelp <https://wiki.gnome.org/Apps/Devhelp>`__
+ support file that allows the GNOME Devhelp reader to view them.
+
+- .. autoattribute:: name
+-
+- .. autoattribute:: format
+-
+- .. autoattribute:: supported_image_types
+-
+ .. versionchanged:: 2.0
+
+ Moved to sphinxcontrib.devhelp from sphinx.builders package.
+diff --git a/sphinx/application.py b/sphinx/application.py
+index 73c157d..ebb47ca 100644
+--- a/sphinx/application.py
++++ b/sphinx/application.py
+@@ -116,7 +116,6 @@ _first_party_themes = (
+ 'alabaster',
+ )
+ builtin_extensions += _first_party_themes
+-builtin_extensions += _first_party_extensions
+
+ ENV_PICKLE_FILENAME = 'environment.pickle'
+
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..fe0e669
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1,11 @@
+skip_tests_network.diff
+no_external_css.diff
+remove_contrib_references.diff
+skip_tests_jsmath.diff
+use_packaged_mathjax.diff
+skip_tests_serializinghtml.diff
+move_sphinxcontrib_to_extras_require.diff
+intersphinx_local.diff
+support_old_search_indexes.diff
+docutils_manpage_macros.diff
+python_3.11.7.diff
diff --git a/debian/patches/skip_tests_jsmath.diff b/debian/patches/skip_tests_jsmath.diff
new file mode 100644
index 0000000..32647a4
--- /dev/null
+++ b/debian/patches/skip_tests_jsmath.diff
@@ -0,0 +1,36 @@
+From: Dmitry Shachnev <mitya57@debian.org>
+Date: Wed, 25 Dec 2019 23:37:50 +0300
+Subject: Skip tests that require sphinxcontrib.jsmath module
+
+---
+ tests/test_build_html.py | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/tests/test_build_html.py b/tests/test_build_html.py
+index 07f101d..beef440 100644
+--- a/tests/test_build_html.py
++++ b/tests/test_build_html.py
+@@ -1544,6 +1544,7 @@ def test_html_math_renderer_is_imgmath(app, status, warning):
+ assert app.builder.math_renderer_name == 'imgmath'
+
+
++@pytest.mark.skip('Requires sphinxcontrib.jsmath module')
+ @pytest.mark.sphinx('html', testroot='basic',
+ confoverrides={'extensions': ['sphinxcontrib.jsmath',
+ 'sphinx.ext.imgmath']})
+@@ -1564,6 +1565,7 @@ def test_html_math_renderer_is_duplicated2(app, status, warning):
+ assert app.builder.math_renderer_name == 'imgmath' # The another one is chosen
+
+
++@pytest.mark.skip('Requires sphinxcontrib.jsmath module')
+ @pytest.mark.sphinx('html', testroot='basic',
+ confoverrides={'extensions': ['sphinxcontrib.jsmath',
+ 'sphinx.ext.imgmath'],
+@@ -1572,6 +1574,7 @@ def test_html_math_renderer_is_chosen(app, status, warning):
+ assert app.builder.math_renderer_name == 'imgmath'
+
+
++@pytest.mark.skip('Requires sphinxcontrib.jsmath module')
+ @pytest.mark.sphinx('html', testroot='basic',
+ confoverrides={'extensions': ['sphinxcontrib.jsmath',
+ 'sphinx.ext.mathjax'],
diff --git a/debian/patches/skip_tests_network.diff b/debian/patches/skip_tests_network.diff
new file mode 100644
index 0000000..60fe57c
--- /dev/null
+++ b/debian/patches/skip_tests_network.diff
@@ -0,0 +1,21 @@
+From: Dmitry Shachnev <mitya57@debian.org>
+Date: Tue, 20 Dec 2016 16:37:32 +0300
+Subject: Skip tests that require network access
+
+Forwarded: not-needed
+---
+ tests/test_build_latex.py | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/tests/test_build_latex.py b/tests/test_build_latex.py
+index f6c3369..5996203 100644
+--- a/tests/test_build_latex.py
++++ b/tests/test_build_latex.py
+@@ -1420,6 +1420,7 @@ def test_latex_raw_directive(app, status, warning):
+ assert 'LaTeX: abc def ghi' in result
+
+
++@pytest.mark.skip('Requires internet access')
+ @pytest.mark.sphinx('latex', testroot='images')
+ def test_latex_images(app, status, warning):
+ app.builder.build_all()
diff --git a/debian/patches/skip_tests_serializinghtml.diff b/debian/patches/skip_tests_serializinghtml.diff
new file mode 100644
index 0000000..b9401cc
--- /dev/null
+++ b/debian/patches/skip_tests_serializinghtml.diff
@@ -0,0 +1,28 @@
+From: Dmitry Shachnev <mitya57@debian.org>
+Date: Thu, 6 Feb 2020 23:55:28 +0300
+Subject: Skip tests that require sphinxcontrib.serializinghtml module
+
+---
+ tests/test_api_translator.py | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/tests/test_api_translator.py b/tests/test_api_translator.py
+index 2185fb8..66aa17f 100644
+--- a/tests/test_api_translator.py
++++ b/tests/test_api_translator.py
+@@ -36,6 +36,7 @@ def test_singlehtml_set_translator_for_singlehtml(app, status, warning):
+ assert translator_class.__name__ == 'ConfSingleHTMLTranslator'
+
+
++@pytest.mark.skip('Requires sphinxcontrib.serializinghtml module')
+ @pytest.mark.sphinx('pickle', testroot='api-set-translator')
+ def test_pickle_set_translator_for_pickle(app, status, warning):
+ translator_class = app.builder.get_translator_class()
+@@ -43,6 +44,7 @@ def test_pickle_set_translator_for_pickle(app, status, warning):
+ assert translator_class.__name__ == 'ConfPickleTranslator'
+
+
++@pytest.mark.skip('Requires sphinxcontrib.serializinghtml module')
+ @pytest.mark.sphinx('json', testroot='api-set-translator')
+ def test_json_set_translator_for_json(app, status, warning):
+ translator_class = app.builder.get_translator_class()
diff --git a/debian/patches/support_old_search_indexes.diff b/debian/patches/support_old_search_indexes.diff
new file mode 100644
index 0000000..450e5e8
--- /dev/null
+++ b/debian/patches/support_old_search_indexes.diff
@@ -0,0 +1,48 @@
+From: Dmitry Shachnev <mitya57@debian.org>
+Date: Sat, 11 Dec 2021 19:19:27 +0300
+Subject: Make searchtools.js support documentation built with old Sphinx
+
+Sphinx 4.3 has changed format of searchindex.js files, but in Debian
+there are lots of packages built with older Sphinx, and we want to
+keep them working for some time.
+
+Also support legacy custom search.html templates, which don't have
+data-content_root attribute on the top-level element.
+
+Forwarded: not-needed
+---
+ sphinx/themes/basic/static/searchtools.js | 12 ++++++++----
+ 1 file changed, 8 insertions(+), 4 deletions(-)
+
+diff --git a/sphinx/themes/basic/static/searchtools.js b/sphinx/themes/basic/static/searchtools.js
+index 7918c3f..09d6458 100644
+--- a/sphinx/themes/basic/static/searchtools.js
++++ b/sphinx/themes/basic/static/searchtools.js
+@@ -62,7 +62,8 @@ const _displayItem = (item, searchTerms, highlightTerms) => {
+ const docFileSuffix = DOCUMENTATION_OPTIONS.FILE_SUFFIX;
+ const docLinkSuffix = DOCUMENTATION_OPTIONS.LINK_SUFFIX;
+ const showSearchSummary = DOCUMENTATION_OPTIONS.SHOW_SEARCH_SUMMARY;
+- const contentRoot = document.documentElement.dataset.content_root;
++ const contentRoot = document.documentElement.dataset.content_root
++ ?? DOCUMENTATION_OPTIONS.URL_ROOT;
+
+ const [docName, title, anchor, descr, score, _filename] = item;
+
+@@ -434,11 +435,14 @@ const Search = {
+ filenames[match[0]],
+ ]);
+ };
+- Object.keys(objects).forEach((prefix) =>
++ Object.keys(objects).forEach((prefix) => {
++ if (!(objects[prefix] instanceof Array)) {
++ objects[prefix] = Object.entries(objects[prefix]).map(([name, match]) => [...match, name]);
++ }
+ objects[prefix].forEach((array) =>
+ objectSearchCallback(prefix, array)
+- )
+- );
++ );
++ });
+ return results;
+ },
+
diff --git a/debian/patches/use_packaged_mathjax.diff b/debian/patches/use_packaged_mathjax.diff
new file mode 100644
index 0000000..28405ca
--- /dev/null
+++ b/debian/patches/use_packaged_mathjax.diff
@@ -0,0 +1,20 @@
+From: Dmitry Shachnev <mitya57@debian.org>
+Date: Tue, 4 Feb 2020 00:12:18 +0300
+Subject: Use packaged MathJax (for our own documentation)
+
+---
+ doc/conf.py | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/doc/conf.py b/doc/conf.py
+index d4915aa..416158f 100644
+--- a/doc/conf.py
++++ b/doc/conf.py
+@@ -185,6 +185,7 @@ nitpick_ignore = {
+ ('std:confval', 'globaltoc_maxdepth'),
+ }
+
++mathjax_path = 'file:///usr/share/javascript/mathjax/MathJax.js?config=TeX-AMS-MML_HTMLorMML'
+
+ # -- Extension interface -------------------------------------------------------
+