summaryrefslogtreecommitdiffstats
path: root/debian/patches
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--debian/patches/data_uris.diff66
-rw-r--r--debian/patches/docutils_manpage_macros.diff6
-rw-r--r--debian/patches/intersphinx_local.diff12
-rw-r--r--debian/patches/move_sphinxcontrib_to_extras_require.diff14
-rw-r--r--debian/patches/python_3.12.4.diff33
-rw-r--r--debian/patches/remove_contrib_references.diff6
-rw-r--r--debian/patches/series2
-rw-r--r--debian/patches/use_packaged_mathjax.diff4
8 files changed, 21 insertions, 122 deletions
diff --git a/debian/patches/data_uris.diff b/debian/patches/data_uris.diff
deleted file mode 100644
index 37dd50a..0000000
--- a/debian/patches/data_uris.diff
+++ /dev/null
@@ -1,66 +0,0 @@
-From: James Addison <55152140+jayaddison@users.noreply.github.com>
-Date: Wed, 3 Jul 2024 02:16:43 +0100
-Subject: Regression: restore extraction of data-URI images from source for
- builders whose output formats do not support them natively (#12344)
-
-(cherry picked from commit 778013f91a650f585bd7bf346d781d5bd9392e46)
----
- sphinx/transforms/post_transforms/images.py | 4 +---
- tests/roots/test-images/index.rst | 5 +++++
- tests/test_builders/test_build_latex.py | 1 +
- tests/test_builders/test_build_texinfo.py | 1 +
- 4 files changed, 8 insertions(+), 3 deletions(-)
-
-diff --git a/sphinx/transforms/post_transforms/images.py b/sphinx/transforms/post_transforms/images.py
-index 18ad51d..9a6e1be 100644
---- a/sphinx/transforms/post_transforms/images.py
-+++ b/sphinx/transforms/post_transforms/images.py
-@@ -115,10 +115,8 @@ class DataURIExtractor(BaseImageConverter):
- default_priority = 150
-
- def match(self, node: nodes.image) -> bool:
-- if not self.app.builder.supported_remote_images:
-- return False
- if self.app.builder.supported_data_uri_images is True:
-- return False
-+ return False # do not transform the image; data URIs are valid in the build output
- return node['uri'].startswith('data:')
-
- def handle(self, node: nodes.image) -> None:
-diff --git a/tests/roots/test-images/index.rst b/tests/roots/test-images/index.rst
-index 9b9aac1..f6d7160 100644
---- a/tests/roots/test-images/index.rst
-+++ b/tests/roots/test-images/index.rst
-@@ -27,3 +27,8 @@ test-image
-
- .. non-exist remote image
- .. image:: http://localhost:7777/NOT_EXIST.PNG
-+
-+.. a self-contained image within a data URI
-+ This image was generated using ImageMagick 6.9 with the command ``convert -pointsize 32 -font Noto-Sans-Egyptian-Hieroglyphs-Regular caption:$(printf '\U13080') -trim -border 2 -monochrome eoh.png``
-+.. image:: data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAACoAAAAjAQAAAADKt6U+AAAAAmJLR0QAAd2KE6QAAAAHdElNRQfoBQIVBgOBlOMTAAAAEGNhTnYAAAAtAAAAOwAAAAEAAAATst46RgAAAJtJREFUCNdNz70KwkAMAOA8iOhjuGh9HB9BCtoTHHwMH0Mc7KWTmx0dHDpovUk6HCil3sUmATHLR/4IAeJA+LEWPmbEeHJMWbTMZDA0CNFn8x1COFPaIHQ55R7hlZGdIjwj2aovRjJbhPvMLNN+r0g2vB7ByIWbHqqVh3LR3lhZWM0qYV8qjU6+lc4J7ZVx4SjEINBKOSinv/+YL1xvsJE6ztdqAAAADHRFWHRjYXB0aW9uAPCTgoD4hdKUAAAAD3RFWHRjYXB0aW9uOmxpbmVzADGoBz2RAAAAAElFTkSuQmCC
-+ :alt: The Eye of Horus in a black font on a white background.
-diff --git a/tests/test_builders/test_build_latex.py b/tests/test_builders/test_build_latex.py
-index 0776c74..ba8fc62 100644
---- a/tests/test_builders/test_build_latex.py
-+++ b/tests/test_builders/test_build_latex.py
-@@ -1710,6 +1710,7 @@ def test_copy_images(app, status, warning):
- }
- images.discard('sphinx.png')
- assert images == {
-+ 'ba30773957c3fe046897111afd65a80b81cad089.png', # latex: image from data:image/png URI in source
- 'img.pdf',
- 'rimg.png',
- 'testimäge.png',
-diff --git a/tests/test_builders/test_build_texinfo.py b/tests/test_builders/test_build_texinfo.py
-index f9effb2..3b8e276 100644
---- a/tests/test_builders/test_build_texinfo.py
-+++ b/tests/test_builders/test_build_texinfo.py
-@@ -124,6 +124,7 @@ def test_copy_images(app, status, warning):
- images = {image.name for image in images_dir.rglob('*')}
- images.discard('python-logo.png')
- assert images == {
-+ 'ba30773957c3fe046897111afd65a80b81cad089.png', # texinfo: image from data:image/png URI in source
- 'img.png',
- 'rimg.png',
- 'testimäge.png',
diff --git a/debian/patches/docutils_manpage_macros.diff b/debian/patches/docutils_manpage_macros.diff
index b854af4..e56ff00 100644
--- a/debian/patches/docutils_manpage_macros.diff
+++ b/debian/patches/docutils_manpage_macros.diff
@@ -8,12 +8,12 @@ I backported the change from upstream 0.21 to our 0.19 and 0.20 packaging.
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/tests/test_builders/test_build_manpage.py b/tests/test_builders/test_build_manpage.py
-index 7172281..735f597 100644
+index 31d75d6..7563dd7 100644
--- a/tests/test_builders/test_build_manpage.py
+++ b/tests/test_builders/test_build_manpage.py
-@@ -52,7 +52,7 @@ def test_captioned_code_block(app, status, warning):
+@@ -56,7 +56,7 @@ def test_captioned_code_block(app, status, warning):
app.build(force_all=True)
- content = (app.outdir / 'python.1').read_text(encoding='utf8')
+ content = (app.outdir / 'projectnamenotset.1').read_text(encoding='utf8')
- if docutils.__version_info__[:2] < (0, 21):
+ if docutils.__version_info__[:2] < (0, 19):
diff --git a/debian/patches/intersphinx_local.diff b/debian/patches/intersphinx_local.diff
index 8f63354..0d5cf6b 100644
--- a/debian/patches/intersphinx_local.diff
+++ b/debian/patches/intersphinx_local.diff
@@ -10,10 +10,10 @@ during build.
2 files changed, 8 insertions(+), 6 deletions(-)
diff --git a/doc/conf.py b/doc/conf.py
-index 437b08f..8b21457 100644
+index 2e0e42f..8ff28d7 100644
--- a/doc/conf.py
+++ b/doc/conf.py
-@@ -159,9 +159,8 @@ texinfo_documents = [
+@@ -160,9 +160,8 @@ texinfo_documents = [
]
intersphinx_mapping = {
@@ -26,7 +26,7 @@ index 437b08f..8b21457 100644
# Sphinx document translation with sphinx gettext feature uses these settings:
diff --git a/doc/tutorial/deploying.rst b/doc/tutorial/deploying.rst
-index 6b7913f..f5fd24e 100644
+index c269593..d2d8469 100644
--- a/doc/tutorial/deploying.rst
+++ b/doc/tutorial/deploying.rst
@@ -155,13 +155,16 @@ Read the Docs
@@ -39,12 +39,12 @@ index 6b7913f..f5fd24e 100644
+based on this one.
You can publish your sources on GitHub as explained :ref:`in the previous
section <publishing-sources>`, then skip directly to
--:ref:`readthedocs:tutorial/index:Sign up for Read the Docs`.
-+`Sign up for Read the Docs`_.
+-:ref:`readthedocs:tutorial/index:Creating a Read the Docs account`.
++`Creating a Read the Docs account`_.
If you choose GitLab instead, the process is similar.
+.. _the RTD tutorial: https://docs.readthedocs.io/en/stable/tutorial/index.html
-+.. _Sign up for Read the Docs: https://docs.readthedocs.io/en/stable/tutorial/index.html#sign-up-for-read-the-docs
++.. _Creating a Read the Docs account: https://docs.readthedocs.io/en/stable/tutorial/index.html#creating-a-read-the-docs-account
+
GitHub Pages
~~~~~~~~~~~~
diff --git a/debian/patches/move_sphinxcontrib_to_extras_require.diff b/debian/patches/move_sphinxcontrib_to_extras_require.diff
index 8e73096..7f7210b 100644
--- a/debian/patches/move_sphinxcontrib_to_extras_require.diff
+++ b/debian/patches/move_sphinxcontrib_to_extras_require.diff
@@ -7,7 +7,7 @@ Subject: Move sphinxcontrib modules to extras_require
1 file changed, 8 insertions(+), 6 deletions(-)
diff --git a/pyproject.toml b/pyproject.toml
-index 8aa49aa..5dbb696 100644
+index 3d8cce1..d923519 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -56,12 +56,6 @@ classifiers = [
@@ -20,12 +20,12 @@ index 8aa49aa..5dbb696 100644
- "sphinxcontrib-htmlhelp>=2.0.0",
- "sphinxcontrib-serializinghtml>=1.1.9",
- "sphinxcontrib-qthelp",
- "Jinja2>=3.0",
- "Pygments>=2.14",
- "docutils>=0.18.1,<0.22",
-@@ -98,6 +92,14 @@ test = [
- "cython>=3.0",
- "setuptools>=67.0", # for Cython compilation
+ "Jinja2>=3.1",
+ "Pygments>=2.17",
+ "docutils>=0.20,<0.22",
+@@ -99,6 +93,14 @@ test = [
+ "setuptools>=70.0", # for Cython compilation
+ "typing_extensions>=4.9", # for typing_extensions.Unpack
]
+sphinxcontrib = [
+ "sphinxcontrib-applehelp",
diff --git a/debian/patches/python_3.12.4.diff b/debian/patches/python_3.12.4.diff
deleted file mode 100644
index 9e7d09a..0000000
--- a/debian/patches/python_3.12.4.diff
+++ /dev/null
@@ -1,33 +0,0 @@
-From: Bénédikt Tran <10796600+picnixz@users.noreply.github.com>
-Date: Tue, 23 Apr 2024 20:25:34 +0200
-Subject: Fix `sphinx.util.inspect_evaluate_forwardref` for Python 3.12.4
- (#12317)
-
-Python has recently [1] changed the signature of `_evaluate` for forward references
-because of type parameters. The change affects 3.13, and was backported to 3.12.4.
-
-[1]: https://github.com/python/cpython/pull/118104
-
-(cherry picked from commit b5f3ef987ab5c2147d651ad84cc7d72c84ac6acc)
----
- sphinx/util/inspect.py | 7 +++++++
- 1 file changed, 7 insertions(+)
-
-diff --git a/sphinx/util/inspect.py b/sphinx/util/inspect.py
-index 6b13b29..dfb4e40 100644
---- a/sphinx/util/inspect.py
-+++ b/sphinx/util/inspect.py
-@@ -681,6 +681,13 @@ def _evaluate_forwardref(
- localns: dict[str, Any] | None,
- ) -> Any:
- """Evaluate a forward reference."""
-+ if sys.version_info >= (3, 12, 4):
-+ # ``type_params`` were added in 3.13 and the signature of _evaluate()
-+ # is not backward-compatible (it was backported to 3.12.4, so anything
-+ # before 3.12.4 still has the old signature).
-+ #
-+ # See: https://github.com/python/cpython/pull/118104.
-+ return ref._evaluate(globalns, localns, {}, recursive_guard=frozenset()) # type: ignore[arg-type, misc]
- return ref._evaluate(globalns, localns, frozenset())
-
-
diff --git a/debian/patches/remove_contrib_references.diff b/debian/patches/remove_contrib_references.diff
index ce28b5b..a3d946d 100644
--- a/debian/patches/remove_contrib_references.diff
+++ b/debian/patches/remove_contrib_references.diff
@@ -10,7 +10,7 @@ dependency loops anyway.
2 files changed, 25 deletions(-)
diff --git a/doc/usage/builders/index.rst b/doc/usage/builders/index.rst
-index 9c538ee..21763c1 100644
+index e293399..2625fe3 100644
--- a/doc/usage/builders/index.rst
+++ b/doc/usage/builders/index.rst
@@ -121,12 +121,6 @@ The most common builders are:
@@ -66,10 +66,10 @@ index 9c538ee..21763c1 100644
Moved to sphinxcontrib.devhelp from sphinx.builders package.
diff --git a/sphinx/application.py b/sphinx/application.py
-index 7d16d9a..3791738 100644
+index 3935e70..d805b06 100644
--- a/sphinx/application.py
+++ b/sphinx/application.py
-@@ -116,7 +116,6 @@ _first_party_themes = (
+@@ -118,7 +118,6 @@ _first_party_themes = (
'alabaster',
)
builtin_extensions += _first_party_themes
diff --git a/debian/patches/series b/debian/patches/series
index c1297eb..f33bbe2 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -6,5 +6,3 @@ skip_tests_serializinghtml.diff
move_sphinxcontrib_to_extras_require.diff
intersphinx_local.diff
docutils_manpage_macros.diff
-python_3.12.4.diff
-data_uris.diff
diff --git a/debian/patches/use_packaged_mathjax.diff b/debian/patches/use_packaged_mathjax.diff
index e9694da..e2e4a91 100644
--- a/debian/patches/use_packaged_mathjax.diff
+++ b/debian/patches/use_packaged_mathjax.diff
@@ -7,10 +7,10 @@ Subject: Use packaged MathJax (for our own documentation)
1 file changed, 1 insertion(+)
diff --git a/doc/conf.py b/doc/conf.py
-index 49fcba4..437b08f 100644
+index 9582f79..2e0e42f 100644
--- a/doc/conf.py
+++ b/doc/conf.py
-@@ -230,6 +230,7 @@ nitpick_ignore = {
+@@ -236,6 +236,7 @@ nitpick_ignore = {
('std:confval', 'globaltoc_maxdepth'),
}