summaryrefslogtreecommitdiffstats
path: root/doc/development/builders.rst
diff options
context:
space:
mode:
Diffstat (limited to 'doc/development/builders.rst')
-rw-r--r--doc/development/builders.rst18
1 files changed, 6 insertions, 12 deletions
diff --git a/doc/development/builders.rst b/doc/development/builders.rst
index bb67770..7792fbd 100644
--- a/doc/development/builders.rst
+++ b/doc/development/builders.rst
@@ -10,25 +10,19 @@ Discover builders by entry point
that they do not have to be listed in the :confval:`extensions` configuration
value.
-Builder extensions should define an entry point in the ``sphinx.builders``
+Builder extensions should define an entry point in the ``"sphinx.builders"``
group. The name of the entry point needs to match your builder's
:attr:`~.Builder.name` attribute, which is the name passed to the
:option:`sphinx-build -b` option. The entry point value should equal the
dotted name of the extension module. Here is an example of how an entry point
-for 'mybuilder' can be defined in the extension's ``setup.py``
+for 'mybuilder' can be defined in the extension's ``pyproject.toml``
-.. code-block:: python
+.. code-block:: toml
- setup(
- # ...
- entry_points={
- 'sphinx.builders': [
- 'mybuilder = my.extension.module',
- ],
- }
- )
+ [project.entry-points."sphinx.builders"]
+ mybuilder = "my.extension.module"
Note that it is still necessary to register the builder using
:meth:`~.Sphinx.add_builder` in the extension's :func:`setup` function.
-.. _entry points: https://setuptools.readthedocs.io/en/latest/setuptools.html#dynamic-discovery-of-services-and-plugins
+.. _entry points: https://setuptools.pypa.io/en/latest/userguide/entry_point.html